uva10817(注意输入的解决)

题目描述:
The headmaster of Spring
Field School is considering
employing some new
teachers for certain subjects.
There are a number of teachers
applying for the posts.
Each teacher is able to teach
one or more subjects. The
headmaster wants to select
applicants so that each subject
is taught by at least two
teachers, and the overall cost
is minimized.
Input
The input consists of several
test cases. The format of
each of them is explained below:
The first line contains three positive integers S, M and N. S (≤ 8) is the number of subjects, M
(≤ 20) is the number of serving teachers, and N (≤ 100) is the number of applicants.
Each of the following M lines describes a serving teacher. It first gives the cost of employing him/her
(10000 ≤ C ≤ 50000), followed by a list of subjects that he/she can teach. The subjects are numbered
from 1 to S. You must keep on employing all of them. After that there are N lines, giving the
details of the applicants in the same format.
Input is terminated by a null case where S = 0. This case should not be processed.
Output
For each test case, give the minimum cost to employ the teachers under the constraints.
Sample Input
2 2 2
10000 1
20000 2
30000 1 2
40000 1 2
0 0 0
Sample Output
60000

题意:
某校有n个教师和m个求职者,需要讲授s个课程(1<=s<=8,1<=m<=20,1<=n<=100).已知每人的工资c(10000<=c<=50000)和能教的课程集合,要求支付最少的工资使得每门课都至少有两名教师教学。在职教师不能辞退。

分析:
状态压缩dp,0-1背包问题,对于求职者要么选要么不选,用两个集合s1表示恰好有一个人教的科目集合,s2表示至少有两个人教的科目的集合,而d[i][s1][s2]表示前i个人的最小花费。状态转移方程为d[i][s1][s2]=min(dp(i+1,s0,s1,s2),a[i]+dp(i+1,s0,s1,s2))(当i>=m时)。
最终的结果是dp(0,1<<(s-1),0,0)。

附刘汝佳代码:

#include<cstdio>
#include<cstring>
#include<iostream>
#include<sstream>
using namespace std;

const int maxn = 100 + 20 + 5;
const int maxs = 8;
const int INF = 1000000000;
int m, n, s, c[maxn], st[maxn], d[maxn][1<<maxs][1<<maxs];

// s1是一个人教的科目集合,s2是两个人教的科目集合
int dp(int i, int s0, int s1, int s2) 
{
  if(i == m+n) return s2 == (1<<s) - 1 ? 0 : INF;
  int& ans = d[i][s1][s2];
  if(ans >= 0) return ans;

  ans = INF;
  if(i >= m) ans = dp(i+1, s0, s1, s2); // 不选

  // 选
  int m0 = st[i] & s0, m1 = st[i] & s1;
  s0 ^= m0;
  s1 = (s1 ^ m1) | m0;
  s2 |= m1;
  ans = min(ans, c[i] + dp(i+1, s0, s1, s2));
  return ans;
}

int main() 
{
  int x;
  string line;
  while(getline(cin, line)) 
  {
    stringstream ss(line);
    ss >> s >> m >> n;
    if(s == 0) break;

    for(int i = 0; i < m+n; i++) 
    {
      getline(cin, line);
      stringstream ss(line);
      ss >> c[i];
      st[i] = 0;
      while(ss >> x) st[i] |= (1 << (x-1));
    }
    memset(d, -1, sizeof(d));
    cout << dp(0, (1<<s)-1, 0, 0) << "\n";
  }
  return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值