poj2635

The Embarrassed Cryptographer
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 13810 Accepted: 3758
Description

The young and very promising cryptographer Odd Even has implemented the security module of a large system with thousands of users, which is now in use in his company. The cryptographic keys are created from the product of two primes, and are believed to be secure because there is no known method for factoring such a product effectively.
What Odd Even did not think of, was that both factors in a key should be large, not just their product. It is now possible that some of the users of the system have weak keys. In a desperate attempt not to be fired, Odd Even secretly goes through all the users keys, to check if they are strong enough. He uses his very poweful Atari, and is especially careful when checking his boss’ key.

Input

The input consists of no more than 20 test cases. Each test case is a line with the integers 4 <= K <= 10100 and 2 <= L <= 106. K is the key itself, a product of two primes. L is the wanted minimum size of the factors in the key. The input set is terminated by a case where K = 0 and L = 0.
Output

For each number K, if one of its factors are strictly less than the required L, your program should output “BAD p”, where p is the smallest factor in K. Otherwise, it should output “GOOD”. Cases should be separated by a line-break.
Sample Input

143 10
143 20
667 20
667 30
2573 30
2573 40
0 0
Sample Output

GOOD
BAD 11
GOOD
BAD 23
GOOD
BAD 31
Source

Nordic 2005

题目网址http://poj.org/problem?id=2635

题意
给定两个大素数的乘积K,K是一个大数,再给定一个int内的数L

问这两个大素数中最小的一个是否小于L,如果存在小于L的数则输出”BAD p”,p是指这个素数,不存在就输出”GOOD”。

题解:
由素数唯一分解定理,若在小于L的数中存在K的因子,那么必唯一存在,因为K只能分解成这两个数的乘积,因此,只需要枚举小于L的素数,判断其是否为K的因子即可!素数可以提前打好表,大数K用字符数组读入,一开始我写判断K是否能整除某个素数时是直接用字符数组每一位计算,类似于十进制:

bool ok(char* s,int m)
{
    int p=0,len=strlen(s);
    for(int i=0;i<len;i++)
    {
        p=(p*10+(s[i]-'0'))%m;
    }
    return p==0;
}

后来提交上去超时了,后来看了邝斌的博客(http://www.cnblogs.com/kuangbin/archive/2012/04/01/2429463.html)才知道应该转换成千进制用整形数组保存后在进行计算才能过,长知识了~然后改成千进制用数组保存后就过了,附上代码:

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int maxn=105;
const int Maxn=1e6+5;
int a[Maxn],ss[maxn];
char s[maxn];

void init()
{
    for(int i=2;i<Maxn;i++)
    a[i]=1;
    for(int i=2;i*i<Maxn;i++)
     if(a[i])
      for(int j=i*i;j<Maxn;j+=i)
      a[j]=0;
}

bool ok(int m);

int main()
{

    //freopen("in.txt","r",stdin);
    int b;
    init();
    while(~scanf("%s%d",s,&b))
    {
        if(s[0]=='0'&&b==0)
        break;
        int len=strlen(s);
        for(int i=0;i<len/3;i++)  //转为千进制
        {
            ss[i]=(s[3*i]-'0')*100+(s[3*i+1]-'0')*10+s[3*i+2]-'0';
        }
        int q=0;
        for(int i=(len/3)*3;s[i];i++)
        q=(s[i]-'0')+q*10;
        ss[len/3]=q;
        bool flag=false;
        int ans=0;
        for(int i=2;i<b;i++)
         if(a[i])
         if(ok(i))
         {
            flag=true;
            ans=i;
            break;
         }
        if(flag)
        printf("BAD %d\n",ans);
        else printf("GOOD\n");
    }
} 

bool ok(int m)
{
    int p=0,len=strlen(s);
    for(int i=0;i<len/3;i++)
    {
        p=(p*1000+ss[i])%m;
    }
    if(len%3)  //最后一个千进制位不知道存了几位数,要另行讨论!
    {
        int num=len%3;
        int f=1;
        for(int i=0;i<num;i++)
        f*=10;
        p=(p*f+ss[len/3])%m;
    }
    return p==0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值