HDU3400(三分)

Line belt

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3906 Accepted Submission(s): 1513

Problem Description
In a two-dimensional plane there are two line belts, there are two segments AB and CD, lxhgww’s speed on AB is P and on CD is Q, he can move with the speed R on other area on the plane.
How long must he take to travel from A to D?

Input
The first line is the case number T.
For each case, there are three lines.
The first line, four integers, the coordinates of A and B: Ax Ay Bx By.
The second line , four integers, the coordinates of C and D:Cx Cy Dx Dy.
The third line, three integers, P Q R.
0<= Ax,Ay,Bx,By,Cx,Cy,Dx,Dy<=1000
1<=P,Q,R<=10

Output
The minimum time to travel from A to D, round to two decimals.

Sample Input
1
0 0 0 100
100 0 100 100
2 2 1

Sample Output
136.60

利用凸性三分即可。

#include<iostream>
#include<cstdio>
#include<cmath>
#include<algorithm>
using namespace std;
const double eps=1e-5;
double p,q,v;
struct point
{
    double x,y;
};
double len(point a,point b)
{
    return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}
double solve(point a,point b,point c)
{
    point l=b,r=c;
    while(len(l,r)>eps)
    {
        point mid,mmid;
        mid.x=(l.x+r.x)/2,mid.y=(l.y+r.y)/2;
        mmid.x=(l.x+mid.x)/2,mmid.y=(l.y+mid.y)/2;
        double t1=len(mid,a)/v+len(mid,c)/q;
        double t2=len(a,mmid)/v+len(mmid,c)/q;
        if(t1>t2) r=mid;
        else l=mmid;
    }
    return len(a,l)/v+len(l,c)/q;
}

double solve2(point a,point b,point c,point d)
{
    point l=a,r=b;
    while(len(l,r)>eps)
    {
        point mid,mmid;
        mid.x=(l.x+r.x)/2,mid.y=(l.y+r.y)/2;
        mmid.x=(l.x+mid.x)/2,mmid.y=(l.y+mid.y)/2;
        double t1=len(a,mid)/p+solve(mid,c,d);
        double t2=len(a,mmid)/p+solve(mmid,c,d);
        if(t1>t2) r=mid;
        else l=mmid;
    }
    return len(a,l)/p+solve(l,c,d);
}


int main()
{
    int cas;
    scanf("%d",&cas);
    while(cas--)
    {
        point a,b,c,d;

        scanf("%lf%lf%lf%lf%lf%lf%lf%lf",&a.x,&a.y,&b.x,&b.y,&c.x,&c.y,&d.x,&d.y);
        scanf("%lf%lf%lf",&p,&q,&v);
        printf("%.2lf\n",solve2(a,b,c,d));
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值