hdu5876 Sparse Graph(补图最短路)

题目链接

Sparse Graph

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 228    Accepted Submission(s): 81


Problem Description
In graph theory, the  complement  of a graph  G  is a graph  H  on the same vertices such that two distinct vertices of  H  are adjacent if and only if they are  not  adjacent in G

Now you are given an undirected graph  G  of  N  nodes and  M  bidirectional edges of  unit  length. Consider the complement of  G , i.e.,  H . For a given vertex  S  on  H , you are required to compute the shortest distances from  S  to all  N1  other vertices.
 

Input
There are multiple test cases. The first line of input is an integer  T(1T<35)  denoting the number of test cases. For each test case, the first line contains two integers  N(2N200000)  and  M(0M20000) . The following  M  lines each contains two distinct integers  u,v(1u,vN)  denoting an edge. And  S (1SN)  is given on the last line.
 

Output
For each of  T  test cases, print a single line consisting of  N1  space separated integers, denoting shortest distances of the remaining  N1  vertices from  S  (if a vertex cannot be reached from S, output ``-1" (without quotes) instead) in ascending order of vertex number.
 

Sample Input
  
  
1 2 0 1
 

Sample Output
  
  
1
 

Source



题意:n 个点的无向完全图(每条边边权为1)中删除 m 条边,问点 s 到其他点的最短路长度。


题解:
补图上的 BFS 是非常经典的问题。一般的做法是用链表(或者偷懒用 std::set)维护还没 BFS 过的点。当要扩展点 u 的时候,遍历一次还没访问过的点 v,如果 uv 没边,那么将 v 入队。否则将 v 留在未扩展点中。
很明显,后者只会发生 m 次,前者只会发生 n 次,所以复杂度是 O(n + m)O(n+m).与scu4444类似。

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <set>
#include <queue>
using namespace std;
typedef long long LL;
const int INF=0x3f3f3f3f;
const int MAXN=200100;
const int MAXM=20000*4;
int n,m;
int a,b,dis[MAXN];
int q[MAXN];
set<int>st,ts;
set<int>::iterator it;
int head[MAXN],tol;
set<int> cnt;
void init()
{
    memset(head,-1,sizeof(head));
    tol=0;
}
struct note
{
    int to,next;
}edge[MAXM];
void addedge(int u,int v)
{
    edge[tol].to=v,edge[tol].next=head[u],head[u]=tol++;
}
void bfs(int s)
{
    for(int i=1;i<=n;i++)
        dis[i]=INF;
   st.clear(),ts.clear();
    for(int i=1;i<=n;i++)
        if(i!=s)
        st.insert(i);
    memset(q,0,sizeof(q));
    int front=0,rear=0;
    q[rear++]=s;
    dis[s]=0;
    while(front!=rear)
    {
        int u=q[front++];
        if(front>=MAXN) front=0;
        for(int i=head[u];i!=-1;i=edge[i].next)
        {
            int v=edge[i].to;
            if(st.count(v)==0)continue;
            st.erase(v),ts.insert(v);
        }
        for(it=st.begin();it!=st.end();it++)
        {
            q[rear++]=*it;
            if(rear>=MAXN) rear=0;
            dis[*it]=dis[u]+1;
        }
        st.swap(ts);
        ts.clear();
    }
}
int main()
{
    int cas;
    scanf("%d",&cas);
    while(cas--)
    {
        scanf("%d%d",&n,&m);
        init();
        for(int i=0;i<m;i++)
        {
            int u,v;
            scanf("%d%d",&u,&v);
            if(u>v)swap(u,v);
            if(u!=v)
            {
                addedge(u,v);
               addedge(v,u);
            }
        }
        memset(dis,0,sizeof(dis));
        int s;
        scanf("%d",&s);
        bfs(s);
        for(int i=1;i<=n;i++)
        {
            if(i!=s)
            {
                if(dis[i]>=INF) printf("-1");
                else printf("%d",dis[i]);
                if(i!=n) printf(" ");
            }
        }
        printf("\n");
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值