hdu 4726 Kia's Calculation(贪心,好题)

题目链接

Kia's Calculation

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3283    Accepted Submission(s): 702


Problem Description
Doctor Ghee is teaching Kia how to calculate the sum of two integers. But Kia is so careless and alway forget to carry a number when the sum of two digits exceeds 9. For example, when she calculates 4567+5789, she will get 9246, and for 1234+9876, she will get 0. Ghee is angry about this, and makes a hard problem for her to solve:
Now Kia has two integers A and B, she can shuffle the digits in each number as she like, but leading zeros are not allowed. That is to say, for A = 11024, she can rearrange the number as 10124, or 41102, or many other, but 02411 is not allowed.
After she shuffles A and B, she will add them together, in her own way. And what will be the maximum possible sum of A "+" B ?
 

Input
The rst line has a number T (T <= 25) , indicating the number of test cases.
For each test case there are two lines. First line has the number A, and the second line has the number B.
Both A and B will have same number of digits, which is no larger than 10 6, and without leading zeros.
 

Output
For test case X, output "Case #X: " first, then output the maximum possible sum without leading zeros.
 

Sample Input
   
   
1 5958 3036
 

Sample Output
   
   
Case #1: 8984
 

Source


一道很好的贪心题,不过处处是坑,先确定最高位,不能有前导0,然后依次确定后面的位,做法详见代码。
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<vector>
using namespace std;
const int MAXN=2*1e6+100;
char s1[MAXN],s2[MAXN];
int ans[MAXN];
int cnt1[20],cnt2[20];
int main()
{
	int cas;
	scanf("%d",&cas);
	for(int k=1;k<=cas;k++)
	{
		memset(cnt1,0,sizeof(cnt1));
		memset(cnt2,0,sizeof(cnt2));
		memset(ans,0,sizeof(ans));
		scanf("%s%s",s1,s2);
		int len=strlen(s1);
		if(len==1)
		{
			int a=s1[0]-'0',b=s2[0]-'0';
			printf("Case #%d: %d\n",k,(a+b)%10);
			continue;
		}
		for(int i=0;i<len;i++) cnt1[s1[i]-'0']++,cnt2[s2[i]-'0']++;
		int p=0,q=0,tt=-1;
		for(int i=1;i<=9;i++)
		 for(int j=1;j<=9;j++)
		 if(cnt1[i]&&cnt2[j]) 
		 {
		 	if((i+j)%10>tt) tt=(i+j)%10,p=i,q=j;
		 }
		ans[1]=tt;
		int tot=1;
		cnt1[p]--,cnt2[q]--;
		for(int l=9;l>=0;l--)
		{
			for(int i=0;i<=9;i++)
			{
				if(!cnt1[i]) continue;
				int p;
				if(i<=l)
				p=l-i;
				else p=l-i+10;
				int q=min(cnt1[i],cnt2[p]);
				cnt1[i]-=q;
				cnt2[p]-=q;
				while(q--) ans[++tot]=l;
			}
		}
		printf("Case #%d: ",k);
		int s=1;
		while(s<tot&&ans[s]==0) s++;//注意不是小于等于tot,因为最终结果必须要输出一个数,比如90+10. 
		for(int i=s;i<=len;i++) printf("%d",ans[i]);
		printf("\n");
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值