题目链接
Eighty seven
Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 102400/102400 K (Java/Others)Total Submission(s): 843 Accepted Submission(s): 286
Problem Description
Mr. Fib is a mathematics teacher of a primary school. In the next lesson, he is planning to teach children how to add numbers up. Before the class, he will prepare
N
cards with numbers. The number on the
i
-th card is
ai
. In class, each turn he will remove no more than
3
cards and let students choose any ten cards, the sum of the numbers on which is
87
. After each turn the removed cards will be put back to their position. Now, he wants to know if there is at least one solution of each turn. Can you help him?
Input
The first line of input contains an integer
t (t≤5)
, the number of test cases.
t
test cases follow.
For each test case, the first line consists an integer N(N≤50) .
The second line contains N non-negative integers a1,a2,...,aN . The i -th number represents the number on the i -th card. The third line consists an integer Q(Q≤100000) . Each line of the next Q lines contains three integers i,j,k , representing Mr.Fib will remove the i -th, j -th, and k -th cards in this turn. A question may degenerate while i=j , i=k or j=k .
For each test case, the first line consists an integer N(N≤50) .
The second line contains N non-negative integers a1,a2,...,aN . The i -th number represents the number on the i -th card. The third line consists an integer Q(Q≤100000) . Each line of the next Q lines contains three integers i,j,k , representing Mr.Fib will remove the i -th, j -th, and k -th cards in this turn. A question may degenerate while i=j , i=k or j=k .
Output
For each turn of each case, output 'Yes' if there exists at least one solution, otherwise output 'No'.
Sample Input
1 12 1 2 3 4 5 6 7 8 9 42 21 22 10 1 2 3 3 4 5 2 3 2 10 10 10 10 11 11 10 1 1 1 2 10 1 11 12 1 10 10 11 11 12
Sample Output
No No No Yes No Yes No No Yes Yes
Source
题意:
从N个数总去掉第i,j,k位(i,j,k中可能有相等的)数,判断能否在剩下的数中找出10个数使得它们的和为87.
题解:
学习了下bitset,check函数中j从10到1是因为这样可以保证dp[2]恰好是选择2个数所能形成的和的所以可能,如果从1到10转移就不行了。
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<vector>
#include<bitset>
using namespace std;
const int MAXN=55;
int a[MAXN];
bool d[MAXN][MAXN][MAXN];
bitset<90>dp[11];
int n;
bool check(int p,int q,int r)
{
for(int j=0;j<=10;j++) dp[j].reset();
dp[0][0]=true;
for(int i=1;i<=n;i++)
if(i!=p&&i!=q&&i!=r&&a[i]<=87)
for(int j=10;j>0;j--)
dp[j]|=dp[j-1]<<a[i];
return dp[10][87];
}
int main()
{
int cas;
scanf("%d",&cas);
while(cas--)
{
scanf("%d",&n);
for(int i=1;i<=n;i++) scanf("%d",&a[i]);
memset(d,false,sizeof(d));
for(int i=1;i<=n;i++)
for(int j=i;j<=n;j++)
for(int k=j;k<=n;k++)
d[i][j][k]=check(i,j,k);
int q;
scanf("%d",&q);
while(q--)
{
int m[3];
scanf("%d%d%d",&m[0],&m[1],&m[2]);
sort(m,m+3);
if(d[m[0]][m[1]][m[2]]) puts("Yes");
else puts("No");
}
}
return 0;
}