boj 212(栈模拟)

Eliminate Witches!
Accept:9     Submit:38
Time Limit:1000MS     Memory Limit:65536KB
Description

Kaname Madoka is a Magical Girl(Mahou Shoujo/Puella Magi). The duty of a Magical Girl is to eliminate Witches(Majo). Though sounds horrific, it is not a hard job for her as a powerful magical girl. 

One day Madoka is eliminating Witches as usual. This time she is facing a maze full of Witches. The maze consists of rooms, each lives exactly one Witch. And there is exactly one path from one room to another. So you see, the maze can be represented as a tree, with rooms regarded as nodes on the tree. 

Madoka eliminates Witches according to the following rules: 
1. At first, Madoka enters the root node room of the maze. 
2. If the room Madoka enters lives a Witch, Madoka will eliminate it at once, and the Witch disappear. 
3. If the room has child node rooms with Witches, Madoka will choose the leftmost one and enter it. 
4. Madoka won't go back to the parent node room of a room X until Witches living in child node rooms of X are all eliminated. 

See the figure below for details about a sample maze. The numbers inside nodes indicate the order of elimination of the corresponding Witches, the strings below nodes are names of Witches, and the arrow shows the tracks Madoka travels: 


After finishes her task, Madoka just make a brief log like this: 
"walpurgis(charlotte(patricia,gertrud),elly,gisela)" 
which represents the tree-like maze identifying rooms by the names of Witches living in them. 

Akemi Homura, a classmate of Madoka, also a Magical Girl, is a mad fan of her. She wants to take detailed notes of everything Madoka do! Apparently the log Madoka made is hard to read, so Homura decide to make a new one of her own. 

The new log should contain the following information: 
1. The number of rooms of the maze 
2. Names of Witches in all rooms. 
3. The tracks Madoka travels. (represented by the number identifying the node) 

So the new log should be like this: 
walpurgis 
charlotte 
patricia 
gertrud 
elly 
gisela 
1 2 
2 3 
3 2 
2 4 
4 2 
2 1 
1 5 
5 1 
1 6 
6 1 

However, the maze may be very large, so Homura nees a program to help her. 

Input

The first line contains an integer T(T<=20), indicating the number of test cases. 
For each case there is only one string on a line, Madoka's log. 
It is guaranteed that the maze consists of at most 50000 rooms, and the names of Witches is a string consists of at most 10 lowercase characters, while the string of Madoka's log consists of at most 1000000 characters, which are lowercase characters, '(', ')' or ','. 

Output

For each case, you should output the detailed log. 
The first line an integer N, the number of rooms of the maze. 
The following N lines, each line a string, the name of the Witches, in the order of elimination. 
The following 2(N-1) lines, each line two integers, the number of two nodes indicating the path Madoka passes. 
Output a blank line after each case. 

Sample Input 

walpurgis(charlotte(patricia,gertrud),elly,gisela) 
wuzetian 
nanoha(fate(hayate)) 

Sample Output 

walpurgis 
charlotte 
patricia 
gertrud 
elly 
gisela 
1 2 
2 3 
3 2 
2 4 
4 2 
2 1 
1 5 
5 1 
1 6 
6 1 

wuzetian 

nanoha 
fate 
hayate 
1 2 
2 3 
3 2 
2 1
分析:水题,仅提供代码作为参考。。。
代码:
#include<cstdio>
#include<cstring>
using namespace std;
const int mm = 1000007;
const int mn = 55555;
int ans[mm];
int s[mn];
int i, j, r, pr, sr, t, len, tlen, n;
char whole[mm], tmp[33], room[mn][33];
int main() {
    scanf("%d", &t);
    while (t--) {
        scanf("%s", whole);
        len = strlen(whole);
        for (i = tlen = pr = sr = r = n = 0; i < len; ++i) if (whole[i] == '(') {
                tmp[tlen] = '\0';
                strcpy(room[++n], tmp);
                ans[r++] = s[++sr] = n;
                tlen = 0;
            } else if (whole[i] == ')') {
                if (whole[i - 1] == ')') {
                    ans[r++] = s[sr--];
                    continue;
                }
                tmp[tlen] = '\0';
                strcpy(room[++n], tmp);
                ans[r++] = n;
                ans[r++] = s[sr--];
                tlen = 0;
            } else if (whole[i] == ',') {
                if (whole[i - 1] == ')') {
                    ans[r++] = s[sr];
                    continue;
                }
                tmp[tlen] = '\0';
                strcpy(room[++n], tmp);
                ans[r++] = n;
                ans[r++] = s[sr];
                tlen = 0;
            } else tmp[tlen++] = whole[i];
        if (tlen) {
            tmp[tlen] = '\0';
            strcpy(room[++n], tmp);
        }
        printf("%d\n", n);
        for (i = 1; i <= n; ++i)printf("%s\n", room[i]);
        if (n > 1)for (i = 1; i < r; ++i)printf("%d %d\n", ans[i - 1], ans[i]);
        puts("");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值