poj 1948 Triangular Pastures(二维01背包)

Triangular Pastures
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 4333 Accepted: 1295

Description

Like everyone, cows enjoy variety. Their current fancy is new shapes for pastures. The old rectangular shapes are out of favor; new geometries are the favorite. 

I. M. Hei, the lead cow pasture architect, is in charge of creating a triangular pasture surrounded by nice white fence rails. She is supplied with N (3 <= N <= 40) fence segments (each of integer length Li (1 <= Li <= 40) and must arrange them into a triangular pasture with the largest grazing area. Ms. Hei must use all the rails to create three sides of non-zero length. 

Help Ms. Hei convince the rest of the herd that plenty of grazing land will be available.Calculate the largest area that may be enclosed with a supplied set of fence segments. 

Input

* Line 1: A single integer N 

* Lines 2..N+1: N lines, each with a single integer representing one fence segment's length. The lengths are not necessarily unique. 

Output

A single line with the integer that is the truncated integer representation of the largest possible enclosed area multiplied by 100. Output -1 if no triangle of positive area may be constructed. 

Sample Input

5
1
1
3
3
4

Sample Output

692

Hint

[which is 100x the area of an equilateral triangle with side length 4] 

Source

题目:http://poj.org/problem?id=1948

分析:这题算是一题二维的01背包问题吧,状态转移很明显,假设f[i][j]表示第一条边长为i,第二条边长为j,默认i>=j,f[i][j]=f[i][j]|f[j-l[k]][j]|f[i][j=l[k]](1<=k<=n),至于这题注意的地方,那就是求面积是p=(a+b+c)/2.0,这里注意是2.0。。。。这样wa了5++次阿~~~

代码:

#include<cstdio>
#include<iostream>
#include<cmath>
using namespace std;
bool f[888][888];
int l[44];
int area(int x,int y,int z)
{
    double p=(x+y+z)/2.0;
    return int(sqrt(p*(p-x)*(p-y)*(p-z))*100);
}
int main()
{
    int i,j,k,n,m,sum,ans;
    while(scanf("%d",&n)!=-1)
    {
        for(sum=i=0;i<n;++i)scanf("%d",&l[i]),sum+=l[i];
        m=sum/2-((sum&1)==0);
        for(i=0;i<=m;++i)
            for(j=0;j<=i;++j)f[i][j]=0;
        f[0][0]=1;
        for(k=0;k<n;++k)
            for(i=m;i>=0;--i)
                for(j=i;j>=0;--j)
                    if(f[i][j])f[i+l[k]][j]=f[i][j+l[k]]=1;
        ans=-1;
        for(i=1;i<=m;++i)
            for(j=1;j<=i;++j)
                if(f[i][j])ans=max(ans,area(i,j,sum-i-j));
        printf("%d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值