hdu 1394 Minimum Inversion Number(线段树求逆序对)

Minimum Inversion Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3336    Accepted Submission(s): 2026


Problem Description
The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, ..., an-1, an (where m = 0 - the initial seqence)
a2, a3, ..., an, a1 (where m = 1)
a3, a4, ..., an, a1, a2 (where m = 2)
...
an, a1, a2, ..., an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequences.
 

Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.
 

Output
For each case, output the minimum inversion number on a single line.
 

Sample Input
  
  
10 1 3 6 9 0 8 5 7 4 2
 

Sample Output
  
  
16
 

Author
CHEN, Gaoli
 

Source
 

Recommend
Ignatius.L


题目:http://acm.hdu.edu.cn/showproblem.php?pid=1394

分析:这题其实可以求出原序列的逆序对,然后通过推算,算出每种情况的逆序对,因为每次将一个数移到最后,所以只要将原序列的逆序对,加上序列中大于这个数的个数,减去小于这个数的个数,去最小值就行。。。在这题之前我一直以为逆序对只能用归并排序来做= =,线段树的做法就是按顺序插入每个数,插入前获取在线段树中比它大的数的个数,即与这个数相关的逆序对有多少,然后插入线段树统计一下。。。


代码:

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
using namespace std;
const int mm=22222;
int sum[mm],x[mm];
int i,j,k,n,ans,tmp;
void build(int l,int r,int rt)
{
    sum[rt]=0;
    if(l==r)return;
    int m=(l+r)>>1;
    build(lson);
    build(rson);
}
void updata(int p,int l,int r,int rt)
{
    ++sum[rt];
    if(l==r)return;
    int m=(l+r)>>1;
    if(p<=m)updata(p,lson);
    else updata(p,rson);
}
int query(int p,int l,int r,int rt)
{
    if(p<=l)return sum[rt];
    int m=(l+r)>>1,ret=0;
    if(p<=m)ret+=query(p,lson);
    if(m+1<n)ret+=query(p,rson);
    return ret;
}
int main()
{
    while(scanf("%d",&n)!=-1)
    {
        build(0,n-1,1);
        for(tmp=i=0;i<n;++i)
        {
            scanf("%d",&x[i]);
            tmp+=query(x[i],0,n-1,1);
            updata(x[i],0,n-1,1);
        }
        ans=tmp;
        for(i=0;i<n;++i)
        {
            tmp+=n-x[i]-x[i]-1;
            ans=min(ans,tmp);
        }
        printf("%d\n",ans);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值