poj 1873 The Fortified Forest(枚举+凸包边长计算)

The Fortified Forest
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 4056 Accepted: 1161

Description

Once upon a time, in a faraway land, there lived a king. This king owned a small collection of rare and valuable trees, which had been gathered by his ancestors on their travels. To protect his trees from thieves, the king ordered that a high fence be built around them. His wizard was put in charge of the operation. 
Alas, the wizard quickly noticed that the only suitable material available to build the fence was the wood from the trees themselves. In other words, it was necessary to cut down some trees in order to build a fence around the remaining trees. Of course, to prevent his head from being chopped off, the wizard wanted to minimize the value of the trees that had to be cut. The wizard went to his tower and stayed there until he had found the best possible solution to the problem. The fence was then built and everyone lived happily ever after. 

You are to write a program that solves the problem the wizard faced. 

Input

The input contains several test cases, each of which describes a hypothetical forest. Each test case begins with a line containing a single integer n, 2 <= n <= 15, the number of trees in the forest. The trees are identified by consecutive integers 1 to n. Each of the subsequent n lines contains 4 integers xi, yi, vi, li that describe a single tree. (xi, yi) is the position of the tree in the plane, vi is its value, and li is the length of fence that can be built using the wood of the tree. vi and li are between 0 and 10,000. 
The input ends with an empty test case (n = 0). 

Output

For each test case, compute a subset of the trees such that, using the wood from that subset, the remaining trees can be enclosed in a single fence. Find the subset with minimum value. If more than one such minimum-value subset exists, choose one with the smallest number of trees. For simplicity, regard the trees as having zero diameter. 
Display, as shown below, the test case numbers (1, 2, ...), the identity of each tree to be cut, and the length of the excess fencing (accurate to two fractional digits). 

Display a blank line between test cases. 

Sample Input

6
 0  0  8  3
 1  4  3  2
 2  1  7  1
 4  1  2  3
 3  5  4  6
 2  3  9  8
3
 3  0 10  2
 5  5 20 25
 7 -3 30 32
0

Sample Output

Forest 1
Cut these trees: 2 4 5 
Extra wood: 3.16

Forest 2
Cut these trees: 2 
Extra wood: 15.00

Source

题目:http://poj.org/problem?id=1873

题意:给你n棵树,现在要求从n棵树中砍掉一些树,并用这些树造一个围墙,将剩下的树围起来,每棵树有价值,使得砍掉的树价值和最小,如果有相同方案,使得砍掉的树的数量最小

分析:这题数据范围相当小,直接枚举砍掉哪些树,然后计算这种方案的花费,取最优即可,每次都是求凸包边长,看是否小于砍掉的树的长度,再判断这样的花费是否更小

代码:

#include<cmath>
#include<cstdio>
#include<iostream>
#include<algorithm>
using namespace std;
typedef int mType;
struct Tpoint
{
    mType x,y;
    Tpoint(){}
    Tpoint(mType _x,mType _y):x(_x),y(_y){}
}g[55],q[55],o[55];
Tpoint MakeVector(Tpoint P,Tpoint Q)
{
    return Tpoint(Q.x-P.x,Q.y-P.y);
}
mType CrossProduct(Tpoint P,Tpoint Q)
{
    return P.x*Q.y-P.y*Q.x;
}
mType MultiCross(Tpoint P,Tpoint Q,Tpoint R)
{
    return CrossProduct(MakeVector(Q,P),MakeVector(Q,R));
}
long long SqrDis(Tpoint P,Tpoint Q)
{
    return 1LL*(P.x-Q.x)*(P.x-Q.x)+1LL*(P.y-Q.y)*(P.y-Q.y);
}
bool cmp(Tpoint P,Tpoint Q)
{
    mType tmp=MultiCross(P,Q,g[0]);
    if(tmp<0)return 1;
    if(tmp>0)return 0;
    return SqrDis(P,g[0])>SqrDis(Q,g[0]);
}
void Graham(int n,int &m)
{
    int i,j;
    for(j=i=0;i<n;++i)
        if(g[i].x<g[j].x||(g[i].x==g[j].x&&g[i].y<g[j].y))j=i;
    swap(g[0],g[j]);
    sort(g+1,g+n,cmp);
    q[m=0]=g[0];
    for(i=1;i<n;++i)
    {
        while(m&&MultiCross(q[m-1],q[m],g[i])>0)--m;
        q[++m]=g[i];
    }
}
int v[55],l[55];
int i,n,ans,mcost,state,cs=0;
double ex;
double Dis(Tpoint P,Tpoint Q)
{
    return sqrt(1.0*(P.x-Q.x)*(P.x-Q.x)+1.0*(P.y-Q.y)*(P.y-Q.y));
}
void solve(int s)
{
    int i,cost=0,len=0,num=0,m;
    double need=0;
    for(i=0;i<n;++i)
        if(s&(1<<i))
        {
            cost+=v[i];
            len+=l[i];
        }
        else g[num++]=o[i];
    Graham(num,m);
    q[++m]=q[0];
    for(i=0;i<m;++i)
        need+=Dis(q[i],q[i+1]);
    if(len>=need)
    {
        if(cost<mcost||(cost==mcost&&n-num<ans))
        {
            mcost=cost;
            ans=n-num;
            state=s;
            ex=len-need;
        }
    }
}
int main()
{
    while(scanf("%d",&n),n)
    {
        if(cs)puts("");
        for(i=0;i<n;++i)
            scanf("%d%d%d%d",&o[i].x,&o[i].y,&v[i],&l[i]);
        mcost=1e9;
        for(i=0;i<(1<<n)-1;++i)solve(i);
        printf("Forest %d\nCut these trees: ",++cs);
        for(i=0;i<n;++i)
            if(state&(1<<i))printf("%d ",i+1);
        printf("\nExtra wood: %.2lf\n",ex);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值