poj 2002 Squares(枚举+点hash)

Squares
Time Limit: 3500MS Memory Limit: 65536K
Total Submissions: 12372 Accepted: 4535

Description

A square is a 4-sided polygon whose sides have equal length and adjacent sides form 90-degree angles. It is also a polygon such that rotating about its centre by 90 degrees gives the same polygon. It is not the only polygon with the latter property, however, as a regular octagon also has this property. 

So we all know what a square looks like, but can we find all possible squares that can be formed from a set of stars in a night sky? To make the problem easier, we will assume that the night sky is a 2-dimensional plane, and each star is specified by its x and y coordinates. 

Input

The input consists of a number of test cases. Each test case starts with the integer n (1 <= n <= 1000) indicating the number of points to follow. Each of the next n lines specify the x and y coordinates (two integers) of each point. You may assume that the points are distinct and the magnitudes of the coordinates are less than 20000. The input is terminated when n = 0.

Output

For each test case, print on a line the number of squares one can form from the given stars.

Sample Input

4
1 0
0 1
1 1
0 0
9
0 0
1 0
2 0
0 2
1 2
2 2
0 1
1 1
2 1
4
-2 5
3 7
0 0
5 2
0

Sample Output

1
6
1

Source

题目:http://poj.org/problem?id=2002

题意:给你n个点,问从n个点里面挑出4个点组成不同正方形的个数

分析:最容易想到的方法就是枚举两个点,那么另两个点就可以求出来,求出来后判断下这两个点是否存在,存在就+1,具体的判断只需要把所有点hash下就行

代码:

#include<cstdio>
#include<iostream>
#include<cstring>
using namespace std;
const int mm=1111;
const int mod=100007;
struct point
{
    int x,y;
}g[mm];
struct hashTable
{
    int h[mod],p[mod],size;
    point s[mod];
    int hash(int x,int y)
    {
        return ((x*131+y+mod)&0x7FFFFFFF)%mod;
    }
    void insert(int x,int y)
    {
        int i,id=hash(x,y);
        for(i=h[id];i>=0;i=p[i])
            if(s[i].x==x&&s[i].y==y)return;
        s[size].x=x,s[size].y=y;
        p[size]=h[id],h[id]=size++;
    }
    int find(int x,int y)
    {
        int i,id=hash(x,y);
        for(i=h[id];i>0;i=p[i])
            if(s[i].x==x&&s[i].y==y)return i;
        return 0;
    }
    void clear()
    {
        size=1;
        memset(h,-1,sizeof(h));
    }
}ht;
bool check(point P,point Q)
{
    int add1=P.y-Q.y,add2=Q.x-P.x;
    return ht.find(P.x+add1,P.y+add2)&&ht.find(Q.x+add1,Q.y+add2);
}
int main()
{
    int i,j,n,ans;
    while(scanf("%d",&n),n)
    {
        ht.clear();
        for(i=0;i<n;++i)
        {
            scanf("%d%d",&g[i].x,&g[i].y);
            ht.insert(g[i].x,g[i].y);
        }
        for(ans=i=0;i<n;++i)
            for(j=0;j<n;++j)
                if(i!=j&&check(g[i],g[j]))++ans;
        printf("%d\n",ans/4);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值