poj 2033 DP

题目:
Alphacode
Time Limit: 1000MS        Memory Limit: 30000K
Total Submissions: 9788        Accepted: 3010

Description
Alice and Bob need to send secret messages to each other and are discussing ways to encode their messages:

    Alice: "Let's just use a very simple code: We'll assign 'A' the code word 1, 'B' will be 2, and so on down to 'Z' being assigned 26."
    Bob: "That's a stupid code, Alice. Suppose I send you the word 'BEAN' encoded as 25114. You could decode that in many different ways!”
    Alice: "Sure you could, but what words would you get? Other than 'BEAN', you'd get 'BEAAD', 'YAAD', 'YAN', 'YKD' and 'BEKD'. I think you would be able to figure out the correct decoding. And why would you send me the word ‘BEAN’ anyway?”
    Bob: "OK, maybe that's a bad example, but I bet you that if you got a string of length 500 there would be tons of different decodings and with that many you would find at least two different ones that would make sense."
    Alice: "How many different decodings?"
    Bob: "Jillions!"


For some reason, Alice is still unconvinced by Bob's argument, so she requires a program that will determine how many decodings there can be for a given string using her code.

Input
Input will consist of multiple input sets. Each set will consist of a single line of digits representing a valid encryption (for example, no line will begin with a 0). There will be no spaces between the digits. An input line of '0' will terminate the input and should not be processed

Output
For each input set, output the number of possible decodings for the input string. All answers will be within the range of a long variable.

Sample Input

25114
1111111111
3333333333
0

Sample Output

6
89
1

Source
East Central North America 2004


源代码://思路没有问题  在细节上纠结了半天  最后还是百度找到了0的问题~~囧啊  应该想到的~

如果最后两位数大于26  那么所能组成的单词数就和没有最后一个一样

如果小于26  最后两位数就有两种组合的可能 这样结果就等于没有最后两位和没有最后一位时前面剩下的字符能组成的单词数的和

比较爱WA的就是  中间可能会出现0  10 20 01 02什么的 还有 30以上的 都要注意

#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
int main()
{
    char ch[100000];
    long long sum0,sum1,sum;
    int i;
    while(scanf("%s",ch))
    {
        sum0=1;
        sum1=1;
        sum=1;
        if(strcmp(ch,"0")==0)
            break;
        int len=strlen(ch);
        for(i=1;i<len;i++)
        {
            if(ch[i]=='0'&&(ch[i-1]=='1'||ch[i-1]=='2'))
            {
                sum=sum0;
                sum0=sum1;
                sum1=sum;
            }
            else if(((ch[i-1]-'0')*10+(ch[i]-'0')<=26)&&((ch[i-1]-'0')*10+(ch[i]-'0')>=11))
            {
                sum=sum0+sum1;
                sum0=sum1;
                sum1=sum;
            }
            else
            {
                sum=sum1;
                sum0=sum1;
                sum1=sum;
            }
        }
        printf("%lld\n",sum);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值