HDU 2489

题目:

Minimal Ratio Tree

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1140    Accepted Submission(s): 348


Problem Description
For a tree, which nodes and edges are all weighted, the ratio of it is calculated according to the following equation.




Given a complete graph of n nodes with all nodes and edges weighted, your task is to find a tree, which is a sub-graph of the original graph, with m nodes and whose ratio is the smallest among all the trees of m nodes in the graph.
 


 

Input
Input contains multiple test cases. The first line of each test case contains two integers n (2<=n<=15) and m (2<=m<=n), which stands for the number of nodes in the graph and the number of nodes in the minimal ratio tree. Two zeros end the input. The next line contains n numbers which stand for the weight of each node. The following n lines contain a diagonally symmetrical n×n connectivity matrix with each element shows the weight of the edge connecting one node with another. Of course, the diagonal will be all 0, since there is no edge connecting a node with itself.



All the weights of both nodes and edges (except for the ones on the diagonal of the matrix) are integers and in the range of [1, 100].

The figure below illustrates the first test case in sample input. Node 1 and Node 3 form the minimal ratio tree.

 


 

Output
For each test case output one line contains a sequence of the m nodes which constructs the minimal ratio tree. Nodes should be arranged in ascending order. If there are several such sequences, pick the one which has the smallest node number; if there's a tie, look at the second smallest node number, etc. Please note that the nodes are numbered from 1 .
 


 

Sample Input
  
  
3 2 30 20 10 0 6 2 6 0 3 2 3 0 2 2 1 1 0 2 2 0 0 0
 


 

Sample Output
  
  
1 3 1 2
 


 

Source
 


 

Recommend
gaojie

 

深搜枚举m个点的子图,精度问题害死人。。 判小于的时候要判相减<-(1e-9) 才能对。。

//problem_id hdoj 2489

#include<set>
#include<map>
#include<cmath>
#include<queue>
#include<stack>
#include<vector>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>

using namespace std;

#define INF 0x1f1f1f1f
#define MIN(a,b) ((a)<(b)?(a):(b))
#define MAX(a,b) ((a)>(b)?(a):(b))

int edge_wei[20][20];//边权
int node_wei[20];//点权
bool flag[20];
bool fl[20];

double res;
int dfs_cnt;
bool arr[20];//result array

int n,m;

int mst()
{
	int ret=0;
	int low[20]={0};
	int sta;
	for(int i=1;i<=n;i++)
	{
		if(fl[i])
		{
			sta=i;
			break;
		}
	}
	low[sta]=0;
	flag[sta]=1;
	for(int i=1;i<=n;i++)
	{
		if(fl[i])
		{
			low[i]=edge_wei[sta][i];
		}
	}
	for(int i=1;i<m;i++)
	{
		int min=INF;
		int loc;
		for(int j=1;j<=n;j++)
		{
			if(fl[j]&&!flag[j]&&low[j]<min)
			{
				min=low[j];
				loc=j;
			}
		}
		flag[loc]=1;
		ret+=low[loc];
		for(int j=1;j<=n;j++)
		{
			if(fl[j]&&!flag[j])
			{
				if(edge_wei[loc][j]<low[j])
				{
					low[j]=edge_wei[loc][j];
				}
			}
		}
	}
	return ret;
}

void dfs(int v)
{
	fl[v]=1;
	dfs_cnt++;
	if(dfs_cnt==m)
	{
		memset(flag,0,sizeof(flag));
		int r=mst();
		int sum=0;
		for(int i=1;i<=n;i++)
		{
			if(fl[i])
			{
				sum+=node_wei[i];
			}
		}
		double res_tmp=(double)r/(double)sum;
		if(res_tmp-res<-(1e-9))//精度~~~
		{
			res=res_tmp;
			for(int i=1;i<=n;i++)
			{
				arr[i]=fl[i];
			}
		}
		fl[v]=0;
		dfs_cnt--;
		return;
	}
	for(int i=v+1;i<=n;i++)
	{
		dfs(i);
	}
	fl[v]=0;
	dfs_cnt--;
}

int main()
{
	while(scanf("%d%d",&n,&m),n||m)
	{
		for(int i=1;i<=n;i++)
		{
			scanf("%d",&node_wei[i]);
		}
		for(int i=1;i<=n;i++)
		{
			for(int j=1;j<=n;j++)
			{
				scanf("%d",&edge_wei[i][j]);
			}
		}

		res=(double)INF;
		for(int i=1;i<=n-m+1;i++)
		{
			memset(fl,0,sizeof(fl));
			dfs_cnt=0;
			dfs(i);
		}

		int fir=1;
		for(int i=1;i<=n;i++)
		{
			if(arr[i])
			{
				if(fir)
				{
					fir=0;
					printf("%d",i);
				}
				else
				{
					printf(" %d",i);
				}
			}
		}
		printf("\n");
	}
	return 0;
}


 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值