HDU2489 Minimal Ratio Tree

Minimal Ratio Tree


Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2570 Accepted Submission(s): 760


Problem Description
For a tree, which nodes and edges are all weighted, the ratio of it is calculated according to the following equation.





Given a complete graph of n nodes with all nodes and edges weighted, your task is to find a tree, which is a sub-graph of the original graph, with m nodes and whose ratio is the smallest among all the trees of m nodes in the graph.


Input
Input contains multiple test cases. The first line of each test case contains two integers n (2<=n<=15) and m (2<=m<=n), which stands for the number of nodes in the graph and the number of nodes in the minimal ratio tree. Two zeros end the input. The next line contains n numbers which stand for the weight of each node. The following n lines contain a diagonally symmetrical n×n connectivity matrix with each element shows the weight of the edge connecting one node with another. Of course, the diagonal will be all 0, since there is no edge connecting a node with itself.



All the weights of both nodes and edges (except for the ones on the diagonal of the matrix) are integers and in the range of [1, 100].

The figure below illustrates the first test case in sample input. Node 1 and Node 3 form the minimal ratio tree.




Output
For each test case output one line contains a sequence of the m nodes which constructs the minimal ratio tree. Nodes should be arranged in ascending order. If there are several such sequences, pick the one which has the smallest node number; if there's a tie, look at the second smallest node number, etc. Please note that the nodes are numbered from 1 .


Sample Input
3 2
30 20 10
0 6 2
6 0 3
2 3 0
2 2
1 1
0 2
2 0
0 0


Sample Output
1 3
1 2


Source
2008 Asia Regional Beijing

题意:给出n个点的图和每个点之间的权值和点的权值,要求选出m个点,使得m个点之间边的权值之和比上点的权值之和最小。。。

首先暴力DFS,选出m个点,然后对这m个点做最小生成树就可以了。。。

这题思路很简单,但是还是WA了很多发。。。这题和POJ3925一样,但是POJ上比较两个浮点数直接比较就可以过,HDOJ上比较要考虑精度问题,不考虑会WA。。

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
const int MAXN=20;
const int INF=1<<30;
const double eps=1e-5;
int lowcost[MAXN],w[MAXN][MAXN],ch[MAXN],node[MAXN];
int mp[MAXN][MAXN];
bool vis[MAXN];
int n,m;
int prim(int v0)
{
    int i,j,mincost,minone;
    memset(vis,0,sizeof(vis));
    int sum=0;
    for(i=1;i<=m;i++)
    {
        lowcost[i]=mp[v0][i];
    }
    lowcost[v0]=0;
    vis[v0]=1;
    for(i=1;i<=m-1;i++)
    {
        mincost=INF;
        for(j=1;j<=m;j++)
        {
            if(!vis[j]&&mincost>lowcost[j])
            {
                mincost=lowcost[j];
                minone=j;
            }
        }
        vis[minone]=1;
        sum+=mincost;
        for(j=1;j<=m;j++)
        {
            if(!vis[j]&&mp[minone][j]<lowcost[j])
            {
                lowcost[j]=mp[minone][j];
            }
        }
    }
    return sum;
}
double minans;
int ans[MAXN];
void dfs(int k,int num)
{
    int i,j;
    if(num==m)
    {
        double tot=0;
        for(i=1;i<=m;i++)
            tot+=(double)node[ch[i]];
        for(i=1;i<=m;i++)
        {
            for(j=1;j<=m;j++)
                mp[i][j]=w[ch[i]][ch[j]];
        }
        double sum=prim(1)*1.0;
        double temp=sum/tot;
        if(minans-temp>=eps)
        {
            minans=temp;
            for(i=1;i<=m;i++)
            {
                ans[i]=ch[i];
            }
        }
        return;
    }
    for(i=k+1;i<=n;i++)
    {
        ch[num+1]=i;
        dfs(i,num+1);
    }
}
int main()
{
    int i,j;
    while(scanf("%d%d",&n,&m)==2)
    {
        if(n==0&&m==0)
            break;
        for(i=1;i<=n;i++)
            scanf("%d",&node[i]);
        for(i=1;i<=n;i++)
        {
            for(j=1;j<=n;j++)
            {
                scanf("%d",&w[i][j]);
            }
        }
        minans=INF;
        for(i=1;i<=n;i++)
        {
            ch[1]=i;
            dfs(i,1);
        }
        printf("%d",ans[1]);
        for(i=2;i<=m;i++)
            printf(" %d",ans[i]);
        printf("\n");
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值