优先队列和普通队列的小小不同

杭电1026

Ignatius and the Princess I

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 14463    Accepted Submission(s): 4576
Special Judge


Problem Description
The Princess has been abducted by the BEelzebub feng5166, our hero Ignatius has to rescue our pretty Princess. Now he gets into feng5166's castle. The castle is a large labyrinth. To make the problem simply, we assume the labyrinth is a N*M two-dimensional array which left-top corner is (0,0) and right-bottom corner is (N-1,M-1). Ignatius enters at (0,0), and the door to feng5166's room is at (N-1,M-1), that is our target. There are some monsters in the castle, if Ignatius meet them, he has to kill them. Here is some rules:

1.Ignatius can only move in four directions(up, down, left, right), one step per second. A step is defined as follow: if current position is (x,y), after a step, Ignatius can only stand on (x-1,y), (x+1,y), (x,y-1) or (x,y+1).
2.The array is marked with some characters and numbers. We define them like this:
. : The place where Ignatius can walk on.
X : The place is a trap, Ignatius should not walk on it.
n : Here is a monster with n HP(1<=n<=9), if Ignatius walk on it, it takes him n seconds to kill the monster.

Your task is to give out the path which costs minimum seconds for Ignatius to reach target position. You may assume that the start position and the target position will never be a trap, and there will never be a monster at the start position.
 

Input
The input contains several test cases. Each test case starts with a line contains two numbers N and M(2<=N<=100,2<=M<=100) which indicate the size of the labyrinth. Then a N*M two-dimensional array follows, which describe the whole labyrinth. The input is terminated by the end of file. More details in the Sample Input.
 

Output
For each test case, you should output "God please help our poor hero." if Ignatius can't reach the target position, or you should output "It takes n seconds to reach the target position, let me show you the way."(n is the minimum seconds), and tell our hero the whole path. Output a line contains "FINISH" after each test case. If there are more than one path, any one is OK in this problem. More details in the Sample Output.
 

Sample Input
  
  
5 6 .XX.1. ..X.2. 2...X. ...XX. XXXXX. 5 6 .XX.1. ..X.2. 2...X. ...XX. XXXXX1 5 6 .XX... ..XX1. 2...X. ...XX. XXXXX.
 

Sample Output
  
  
It takes 13 seconds to reach the target position, let me show you the way. 1s:(0,0)->(1,0) 2s:(1,0)->(1,1) 3s:(1,1)->(2,1) 4s:(2,1)->(2,2) 5s:(2,2)->(2,3) 6s:(2,3)->(1,3) 7s:(1,3)->(1,4) 8s:FIGHT AT (1,4) 9s:FIGHT AT (1,4) 10s:(1,4)->(1,5) 11s:(1,5)->(2,5) 12s:(2,5)->(3,5) 13s:(3,5)->(4,5) FINISH It takes 14 seconds to reach the target position, let me show you the way. 1s:(0,0)->(1,0) 2s:(1,0)->(1,1) 3s:(1,1)->(2,1) 4s:(2,1)->(2,2) 5s:(2,2)->(2,3) 6s:(2,3)->(1,3) 7s:(1,3)->(1,4) 8s:FIGHT AT (1,4) 9s:FIGHT AT (1,4) 10s:(1,4)->(1,5) 11s:(1,5)->(2,5) 12s:(2,5)->(3,5) 13s:(3,5)->(4,5) 14s:FIGHT AT (4,5) FINISH God please help our poor hero. FINISH
 附上代码:
这是使用普通队列
#include<iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <stdlib.h>
#include <queue>
using namespace std;
int m,n;
char map[110][110];
bool visit[110][110];
int flag,ans;
int dr[4]={1,-1,0,0};
int dc[4]={0,0,1,-1};
struct node
{
  int x,y,step;
  bool friend operator<(node c1,node c2)
  {
      return c2.step<c1.step;
  }
};
struct p
{
  int x,y,step;
}path[110][110];
bool check(int x,int y)
{
    if(visit[x][y]==1 || map[x][y]=='X' || x<0 || y<0 || x>=m || y>=n)
    {
        return 1;
    }
    return 0;
}
void show(int a,int b,int t)
{
    if(t==1)
    {
        cout<<t<<"s:("<<path[a][b].x<<","<<path[a][b].y<<")->("<<a<<","<<b<<")"<<endl;
        //printf("%ds:(%d,%d)->(%d,%d)\n",t,path[a][b].x,path[a][b].y,a,b);
    }else if(path[a][b].step==1)
    {
        show(path[a][b].x,path[a][b].y,t-1);
        cout<<t<<"s:("<<path[a][b].x<<","<<path[a][b].y<<")->("<<a<<","<<b<<")"<<endl;
    }else{
        --path[a][b].step;
        show(a,b,t-1);
        cout<<t<<"s:FIGHT AT ("<<a<<","<<b<<")"<<endl;
        //printf("%ds:FIGHT AT (%d,%d)\n",t,a,b);
    }
}
void bfs()
{
    queue <node> Q;
    node v1,v2;
    v1.x=0,v1.y=0,v1.step=0;
    visit[v1.x][v1.y]=1;
    Q.push(v1);
    while(!Q.empty())
    {
        v1=Q.front;//普通队列的队头
        Q.pop();
        if(v1.x==m-1 && v1.y==n-1)
        {
            ans=v1.step;
            flag=1;
            return;
        }
        for(int i=0;i<4;i++)
        {
            v2.x=v1.x+dr[i];
            v2.y=v1.y+dc[i];
            if(check(v2.x,v2.y)) continue;
            else if(map[v2.x][v2.y]=='.')
            {
                path[v2.x][v2.y].x=v1.x;
                path[v2.x][v2.y].y=v1.y;
                path[v2.x][v2.y].step=1;
                v2.step=v1.step+1;
                visit[v2.x][v2.y]=1;
                Q.push(v2);
            }else{
                path[v2.x][v2.y].x=v1.x;
                path[v2.x][v2.y].y=v1.y;
                path[v2.x][v2.y].step=map[v2.x][v2.y]-'0'+1;
                v2.step=v1.step+map[v2.x][v2.y]-'0'+1;
                visit[v2.x][v2.y]=1;
                Q.push(v2);
            }
        }
    }
}
int main()
{
    int i,j;
    while(cin>>m>>n && !(n==0 && m==0))
    {
        flag=0;
        for(i=0;i<m;i++)
        {
            for(j=0;j<n;j++)
            {
                cin>>map[i][j];
            }
        }
        memset(visit,0,sizeof(visit));
        bfs();
        if(flag==1)
        {
            cout<<"It takes "<<ans<<" seconds to reach the target position, let me show you the way."<<endl;
            show(m-1,n-1,ans);
        }else{
            cout<<"God please help our poor hero."<<endl;
        }
        cout<<"FINISH"<<endl;
    }
    return 0;
}
测试结果为:

可是如果改为优先队列后:
void bfs()
{
    priority_queue <node> Q;
    node v1,v2;
    v1.x=0,v1.y=0,v1.step=0;
    visit[v1.x][v1.y]=1;
    Q.push(v1);
    while(!Q.empty())
    {
        v1=Q.top();//优先队列的队头
        Q.pop();
        if(v1.x==m-1 && v1.y==n-1)
        {
            ans=v1.step;
            flag=1;
            return;
        }
        for(int i=0;i<4;i++)
        {
            v2.x=v1.x+dr[i];
            v2.y=v1.y+dc[i];
            if(check(v2.x,v2.y)) continue;
            else if(map[v2.x][v2.y]=='.')
            {
                path[v2.x][v2.y].x=v1.x;
                path[v2.x][v2.y].y=v1.y;
                path[v2.x][v2.y].step=1;
                v2.step=v1.step+1;
                visit[v2.x][v2.y]=1;
                Q.push(v2);
            }else{
                path[v2.x][v2.y].x=v1.x;
                path[v2.x][v2.y].y=v1.y;
                path[v2.x][v2.y].step=map[v2.x][v2.y]-'0'+1;
                v2.step=v1.step+map[v2.x][v2.y]-'0'+1;
                visit[v2.x][v2.y]=1;
                Q.push(v2);
            }
        }
    }
}
测试结果为:



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值