POJ-2251-Dungeon Master (BFS)

POJ-2251-Dungeon Master
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 57669 Accepted: 21275
题目链接

Description
You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides.
Is an escape possible? If yes, how long will it take?

Input
The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size).
L is the number of levels making up the dungeon.
R and C are the number of rows and columns making up the plan of each level.
Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a ‘#’ and empty cells are represented by a ‘.’. Your starting position is indicated by ‘S’ and the exit by the letter ‘E’. There’s a single blank line after each level. Input is terminated by three zeroes for L, R and C.

Output
Each maze generates one line of output. If it is possible to reach the exit, print a line of the form
Escaped in x minute(s).

where x is replaced by the shortest time it takes to escape.
If it is not possible to escape, print the line
Trapped!

Sample Input

3 4 5
S....
.###.
.##..
###.#

#####
#####
##.##
##...

#####
#####
#.###
####E

1 3 3
S##
#E#
###

0 0 0

Sample Output

Escaped in 11 minute(s).
Trapped!

题目意思:从’S’走到’E’,只能走’.’,三维迷宫问题。

解题思路:运用BFS进行搜索,从6个方向(qianjin数组存储)进行搜索,v存储最短距离和作为判断是否走过,初始为全-1,s存储迷宫(题目为牢笼),node结构体存储三维坐标,用flag标记能否走到。

代码如下:

#include <iostream>
#include <stdio.h>
#include <cstring>
#include <string.h>
#include <queue>
using namespace std;

struct node{
    int x;
    int y;
    int z;
};

int L, R, C;
int a, b, c;
int x, y, z;
int v[31][31][31];
char s[33][31][31];
bool flag;
queue<node> q;
int ans;
int qianjin[3][6] = {{-1, 0, 0, 1, 0, 0},{0, -1, 0, 0, 1, 0}, {0, 0, -1, 0, 0, 1}};

void bfs()
{
    while(!q.empty()&&!flag)
    {
        node no;		//当前的坐标
        no = q.front();
        q.pop();
        for(int i=0; i<6&&!flag; i++)	//6个方向
        {
            node nod;		//前进的坐标
            nod.x = no.x + qianjin[0][i];
            nod.y = no.y + qianjin[1][i];
            nod.z = no.z + qianjin[2][i];
            if(0<=nod.x&&nod.x<L&&0<=nod.y&&nod.y<R&&0<=nod.z&&nod.z<C&&!flag)
            {
                if(s[nod.x][nod.y][nod.z]=='E')
                {
                    ans = v[nod.x][nod.y][nod.z] = v[no.x][no.y][no.z] + 1;
                    flag = true;		//走到终点了,将flag设置为true便可跳出全部循环
                    break;
                }
                if(v[nod.x][nod.y][nod.z]==-1 && s[nod.x][nod.y][nod.z]=='.')	//-1表示还没走过,'.'表示可以走
                {
                    v[nod.x][nod.y][nod.z] = v[no.x][no.y][no.z] + 1;
                    q.push(nod);
                }
            }
        }
    }
}

int main()
{
    //freopen("Data.txt", "r", stdin);		//从本项目下的Data.txt读取数据,作测试用,提交时记得注释掉

    while(scanf("%d %d %d", &L, &R, &C))
    {
        if(L==0&&R==0&&C==0)
            break;
        memset(v, -1, sizeof(v));	//将v数组初始化为-1
        memset(s, 0, sizeof(s));
        flag = false;
        ans = 0;
        node n;
        while(!q.empty())			//清空队列q
            q.pop();

        for(int i=0; i<L; i++)
        {
            for(int j=0; j<R; j++)
            {
                scanf("%s", s[i][j]);
                for(int k=0; k<C; k++)
                {
                    if(s[i][j][k]=='S')		//找出起点
                    {
                        v[i][j][k] = 0;
                        n.x = i;
                        n.y = j;
                        n.z = k;
                        q.push(n);
                    }
                }
            }
        }

        bfs();

        if(flag)
            printf("Escaped in %d minute(s).\n", ans);
        else
            printf("Trapped!\n");
    }

    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值