poj 2488 A Knight's Journey

这道题的题意是:

给出一个国际棋盘的大小,判断马能否不重复的走过所有格,并记录下其中按字典序排列的第一种路径。经典的“骑士游历”问题、

主要得注意一下需要输入出字典序最小的一种路,所以在dfs的时候要先从第一个点开始,还有就是注意遍历的顺序

字典序小的先遍历 、、

A Knight's Journey
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 25999 Accepted: 8869

Description

Background 
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey 
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans? 

Problem 
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number. 
If no such path exist, you should output impossible on a single line.

Sample Input

3
1 1
2 3
4 3

Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4
#include <stdio.h>
#include <string.h>
#include <iostream>
#include <stdlib.h>

using namespace std;

struct node
{
    int id;
    char s;
} f[1011];
int p, q, x, y;
int map[101][101];
void find(int i, int j, int num)
{
     switch(num)
    {
        case 1: {x=i-1; y=j-2; break;}
        case 2: {x=i+1; y=j-2; break;}
        case 3: {x=i-2; y=j-1; break;}
        case 4: {x=i+2; y=j-1; break;}
        case 5: {x=i-2; y=j+1; break;}
        case 6: {x=i+2; y=j+1; break;}
        case 7: {x=i-1; y=j+2; break;}
        case 8: {x=i+1; y=j+2; break;}
    }
}
int dfs(int i, int j, int step)
{
    map[i][j] = 1;
    f[step].id = i;
    f[step].s = j;
    if(step == f[0].id)
        return 1;
    for(int k = 1; k <= 8; k++)
    {
        find(i, j, k);
        int ii = x, jj = y;
        if(!map[ii][jj] && ii >= 1 && ii <= p && jj >= 'A' && jj <= 'A'+q-1)
            if(dfs(ii, jj, step+1))
                return 1;
    }
    map[i][j] = 0;
    return 0;
}
int main()
{
    int T, t = 1, i, j;
    scanf("%d",&T);
    while(T--)
    {
        memset(map , 0 , sizeof(map));
        scanf("%d %d",&p,&q);
        f[0].id = p*q;
        int flag = 0;
        for(j = 'A'; j <= 'A'+q-1; j++)
        {
            for(i = 1; i <= p; i++)
                if(dfs(i , j , 1))
                {
                    flag = 1;
                    printf("Scenario #%d:\n",t++);
                    for(int k = 1; k <= f[0].id; k++)
                        printf("%c%d",f[k].s, f[k].id);
                    printf("\n\n");
                    break;
                }
            if(flag)
                break;
        }
        if(!flag)
            printf("Scenario #%d:\nimpossible\n\n",t++);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值