POJ 1837 Balance

126 篇文章 2 订阅

首先说一下题意:先输入一个c,g分别代表挂钩的数目和砝码的数目。然后下一行输入挂钩的位置,负的代表在天平的左边,正的代表在天平的右边。最后一行输入砝码的重量。目的是求出有多少种可以是天平达到平衡的方案。

解题的时候需要注意几点:1,砝码必须全部用完;2,挂钩不一定全部挂东西;3,每个砝码这能用一次;4,每个挂钩可以挂多个物品。
解题思路:一开始的时候我是这么理解的枚举每个挂钩,然后判断当前已经使用了几个砝码末状态是整个天平的总重量是0。但是这种枚举很复杂而且还是错的、、因为挂钩可以不挂,而且挂的位置顺序都可以不同。
后来就问崔老师,结果崔老师也记不清了啊、、之后去看宝哥的博客,发现原来是可以加上一个常数之后再枚举的瞬间感觉知道的好少啊、、
下面是报个写的我就借鉴过来了啊,出处http://www.cnblogs.com/E-star/archive/2012/04/20/2459858.html
挂在左边的得到负数,挂在右边得到正数,只要我们的到的数为0就表明此时天平平衡。由于数组下表不能为负,所以我们要加上一个偏移量c = 20*15*25 = 7500 所有重物都挂到一端取最大重量则我们得到的结果dp[g][0] 就等于dp[g][7500] 了(加上偏移量)
Balance
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 9257 Accepted: 5678

Description

Gigel has a strange "balance" and he wants to poise it. Actually, the device is different from any other ordinary balance. 
It orders two arms of negligible weight and each arm's length is 15. Some hooks are attached to these arms and Gigel wants to hang up some weights from his collection of G weights (1 <= G <= 20) knowing that these weights have distinct values in the range 1..25. Gigel may droop any weight of any hook but he is forced to use all the weights. 
Finally, Gigel managed to balance the device using the experience he gained at the National Olympiad in Informatics. Now he would like to know in how many ways the device can be balanced. 

Knowing the repartition of the hooks and the set of the weights write a program that calculates the number of possibilities to balance the device. 
It is guaranteed that will exist at least one solution for each test case at the evaluation. 

Input

The input has the following structure: 
• the first line contains the number C (2 <= C <= 20) and the number G (2 <= G <= 20); 
• the next line contains C integer numbers (these numbers are also distinct and sorted in ascending order) in the range -15..15 representing the repartition of the hooks; each number represents the position relative to the center of the balance on the X axis (when no weights are attached the device is balanced and lined up to the X axis; the absolute value of the distances represents the distance between the hook and the balance center and the sign of the numbers determines the arm of the balance to which the hook is attached: '-' for the left arm and '+' for the right arm); 
• on the next line there are G natural, distinct and sorted in ascending order numbers in the range 1..25 representing the weights' values. 

Output

The output contains the number M representing the number of possibilities to poise the balance.

Sample Input

2 4	
-2 3 
3 4 5 8

Sample Output

2
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <cmath>
#define c 7500

using namespace std;

int dp[22][14050];
int main()
{
    int n, m, p[100], f[100], i, j, k;
    while(~scanf("%d %d",&n, &m))
    {
        memset(dp , 0 , sizeof(dp));
        for(i = 1; i <= n; i++)
            scanf("%d",&p[i]);
        for(i = 1; i <= m; i++)
            scanf("%d",&f[i]);
        for(i = 1; i <= n; i++)
            dp[1][f[1]*p[i] + c] ++;
        for(i = 2; i <= m; i++)
            for(j = 1; j <= n; j++)
                for(k = -7500; k <= 7500; k++)
                    if(dp[i-1][c+k])
                        dp[i][k+f[i]*p[j]+c] += dp[i-1][k+c];
        printf("%d\n",dp[m][7500]);
    }
    return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值