POJ 3258 River Hopscotch

46 篇文章 0 订阅
9 篇文章 0 订阅

先说一下题意:就是给你n个石头,牛在上面跳,然后去掉m个石头之后使得石头之间的距离达到最远,最后输出所有最远距离中最近的那一个、、、

解释一下样例:

25 5 2
2
14
11
21
17

25 代表最后一块石头距离原点25,(第一块石头默认距离是0,第一块和最后一块石头是不可以移动的)。5代表除了第一块和最后一块之外还有5块石头,2代表需要移动2个石头。下面是五块石头分别距离原点的距离。

这道题的思路是二分到原点的距离,使得距离小于某个数的和等于m,就可以了。但是注意二分时候的边界、、有点不好弄啊、、、

River Hopscotch
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 5512 Accepted: 2396

Description

Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end, L units away from the start (1 ≤ L ≤ 1,000,000,000). Along the river between the starting and ending rocks, N (0 ≤ N ≤ 50,000) more rocks appear, each at an integral distance Di from the start (0 < Di < L).

To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river.

Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up to rocks (0 ≤ M ≤ N).

FJ wants to know exactly how much he can increase the shortest distance *before* he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set of M rocks.

Input

Line 1: Three space-separated integers:  LN, and  M 
Lines 2.. N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position.

Output

Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removing  M rocks

Sample Input

25 5 2
2
14
11
21
17

Sample Output

4
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <cmath>
#include <algorithm>
#include <iostream>

using namespace std;

int f[50100];

int main()
{
    int l, n, m, i, mid, low, hight;
    while(cin >>l>>n>>m)
    {
        f[0] = 0;
        for(i = 1; i <= n; i++)
            cin >>f[i];
        f[n+1] = l;
        sort(f , f+(n+2));
        low = 0;
        hight = l;
        while(low <= hight)
        {
            mid = (low+hight)/2;
            int sum = 0, k= 0;
            for(i = 1; i <= n+1; i++)
            {
                if(f[i] - f[k] < mid)
                    sum++;
                else
                    k = i;
            }
            if(sum <= m)
                low = mid+1;
            else
                hight = mid-1;
        }
        cout <<hight<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值