HDU 1224 Free DIY Tour(简单dp?+记录路径)

126 篇文章 2 订阅
12 篇文章 0 订阅

说是dp感觉还不若说是最短路的求法啊,就是每个城市选不选则的依据是之前的是否比他还大。其实感觉就是bfs找到最大值,再记录路径。为毛在HDU的难度还是2啊。不理解啊。。。怎么分的啊、、、

Free DIY Tour

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3311    Accepted Submission(s): 1070


Problem Description
Weiwei is a software engineer of ShiningSoft. He has just excellently fulfilled a software project with his fellow workers. His boss is so satisfied with their job that he decide to provide them a free tour around the world. It's a good chance to relax themselves. To most of them, it's the first time to go abroad so they decide to make a collective tour.

The tour company shows them a new kind of tour circuit - DIY circuit. Each circuit contains some cities which can be selected by tourists themselves. According to the company's statistic, each city has its own interesting point. For instance, Paris has its interesting point of 90, New York has its interesting point of 70, ect. Not any two cities in the world have straight flight so the tour company provide a map to tell its tourists whether they can got a straight flight between any two cities on the map. In order to fly back, the company has made it impossible to make a circle-flight on the half way, using the cities on the map. That is, they marked each city on the map with one number, a city with higher number has no straight flight to a city with lower number. 

Note: Weiwei always starts from Hangzhou(in this problem, we assume Hangzhou is always the first city and also the last city, so we mark Hangzhou both  1 and N+1), and its interesting point is always 0.

Now as the leader of the team, Weiwei wants to make a tour as interesting as possible. If you were Weiwei, how did you DIY it?
 

Input
The input will contain several cases. The first line is an integer T which suggests the number of cases. Then T cases follows.
Each case will begin with an integer N(2 ≤ N ≤ 100) which is the number of cities on the map.
Then N integers follows, representing the interesting point list of the cities.
And then it is an integer M followed by M pairs of integers [Ai, Bi] (1 ≤ i ≤ M). Each pair of [Ai, Bi] indicates that a straight flight is available from City Ai to City Bi.
 

Output
For each case, your task is to output the maximal summation of interesting points Weiwei and his fellow workers can get through optimal DIYing and the optimal circuit. The format is as the sample. You may assume that there is only one optimal circuit. 

Output a blank line between two cases.
 

Sample Input
  
  
2 3 0 70 90 4 1 2 1 3 2 4 3 4 3 0 90 70 4 1 2 1 3 2 4 3 4
 

Sample Output
  
  
CASE 1# points : 90 circuit : 1->3->1 CASE 2# points : 90 circuit : 1->2->1
 

#include <algorithm>
#include <iostream>
#include <stdlib.h>
#include <string.h>
#include <iomanip>
#include <stdio.h>
#include <string>
#include <queue>
#include <cmath>
#include <stack>
#include <map>
#include <set>
#define eps 1e-7
#define M 10001000
#define LL __int64
//#define LL long long
#define INF 0x3f3f3f3f
#define PI 3.1415926535898
const int maxn = 110;

using namespace std;

int dp[maxn];
int Map[maxn][maxn];
int pre[maxn];
int point[maxn];

int main()
{
    int t;
    int n;
    cin >>t;
    for(int k = 1; k <= t; k++)
    {
        cout<<"CASE "<<k<<"#"<<endl;
        cin >>n;
        n++;
        for(int i = 1; i < n; i++)
            cin >>point[i];
        point[n] = 0;
        int m;
        memset(Map , 0 , sizeof(Map));
        cin >>m;
        int x, y;
        for(int i = 1; i <= m; i++)
        {
            cin >>x>>y;
            Map[x][y] = 1;
        }
        memset(dp , 0 , sizeof(dp));
        memset(pre, -1, sizeof(pre));
        for(int i = 1; i <= n; i++)
        {
            for(int j = 1; j <= n; j++)
            {
                if(Map[i][j] && dp[j] < dp[i]+point[i])
                {
                    dp[j] = dp[i]+point[i];
                    pre[j] = i;
                }
            }
        }
        cout<<"points : "<<dp[n]<<endl;
        cout<<"circuit : 1->";

        int u = pre[n];
        int num[maxn];
        int cnt = 0;
        while(u != -1)
        {
            num[cnt++] = u;
            u = pre[u];
        }
        for(int i = cnt-1; i >= 0; i--)
            cout<<num[i]<<"->";
        cout<<"1"<<endl;
        if(k != t)
            cout<<endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值