7-1 Lily
百合花(Lily)是一种美丽的花。她通常一年只开一次花,所以如果你看到百合花盛开,它会非常珍贵。然而,她对猫有剧毒,所以你必须注意让好奇的猫远离可爱的百合花。
你有n个网格的土壤土地排成一行,从1到n,其中一些是百合花。我们不想伤害百合,也不想伤害猫。你可以在网格上放一些猫粮,但对于任何有猫粮的网格i,在区域[i−1,i+1]不得含有百合花。你喜欢猫和百合,所以你想最大限度地增加有猫粮的格子。
设计满足上述要求的计划。
输入格式:
有一个整数n(1≤n≤1000)表示网格的数量。
第二行包含仅由“L”和“.”组成的字符串R,表示有和没有百合花的格子。
输出格式:
输出包含一行,字符串R′仅由“L”、“”组成和“C”,其中“C”表示在满足上述要求的同时分配给R中空网格的猫粮。
输入样例:
在这里给出一组输入。例如:
5
..L..
输出样例:
在这里给出相应的输出。例如:
C.L.C
#include<bits/stdc++.h>
using namespace std;
int main(){
int n,num=0,sum=0,flag=0;cin>>n;
string r;cin>>r;
for(int i=0;i<n;i++){
if(r[i]=='.')r[i]='C';
else if(r[i]=='L'&&i>0){
if(r[i-1]!='L')
r[i-1]='.';
if(i<n-1&&r[i+1]!='L')
i++;
}
}
for(int i=0;i<n;i++)cout<<r[i];
return 0;
}
7-2 a * b
给出两个不超过1000位的十六进制数a,b。
求a∗b的值
输入格式:
输入共两行,两个十六进制的数
输出格式:
输出一行,表示a∗b
输入样例:
在这里给出一组输入。例如:
1BF52
1D4B42
输出样例:
在这里给出相应的输出。例如:
332FCA5924
#include<bits/stdc++.h>
using namespace std;
int a[1003], b[1003], c[1000003];
string s1, s2;
int changetonum(char ch) {
switch (ch) {
case 'A':
return 10;
case 'B':
return 11;
case 'C':
return 12;
case 'D':
return 13;
case 'E':
return 14;
case 'F':
return 15;
default:
return ch - '0';
}
}
char changetochar(int num) {
switch (num) {
case 10:
return 'A';
case 11:
return 'B';
case 12:
return 'C';
case 13:
return 'D';
case 14:
return 'E';
case 15:
return 'F';
default:
return num + '0';
}
}
int main()
{
cin >> s1 >> s2;
int lena = s1.length();
int lenb = s2.length();
for (int i = 1; i <= lena; i++) {
a[i] = changetonum(s1[lena - i]);
}
for (int i = 1; i <= lenb; i++)
b[i] = changetonum(s2[lenb - i]);
for (int i = 1; i <= lena; i++) {
int t = 0;
for (int j = 1; j <= lenb; j++) {
c[i + j - 1] = a[i] * b[j] + t + c[i + j - 1];
t = c[i + j - 1] / 16;
c[i + j - 1] %= 16;
}
c[i + lenb] += t;
}
int lenc = lena + lenb;
while (c[lenc] == 0 && lenc > 0)lenc--;
for (int i = lenc; i >= 1; i--)cout << changetochar(c[i]);
return 0;
}
7-3 山头狙击战
题目描述
小明为了掩护大部队,单枪匹马同敌人周旋,后来被敌人包围在某山头……等等,为什么怎么听怎么像狼牙山五壮士!不过不用着急,这次小明携带了足够的弹药,完全可以将涌上来的敌人一个一个干掉。小明是个神枪手,只要他的枪膛中有子弹,他就能将在他射程m(用从敌人位置到山头的直线距离算)以内的一个敌人瞬间射杀。但如果在射程内没有敌人,出于节约子弹考虑和面子问题,小明会等待敌人靠近然后射击。
正当小明为自己的强大而自我膨胀时,他忽然发现了一个致命的失误:他携带的枪是单发枪,每射出一发子弹都必须花k秒钟的时间装子弹。而凶残的敌人才不会花时间等你换子弹呢。他们始终在以1m/s的速度接近山头。而如果在一个敌人到达山头时小明无法将他击毙,那么我们可怜的小明就将牺牲在敌人的刺刀下。现在小明用心灵感应向你发出求助:要保住自己的性命并且歼灭所有敌人,小明最多只能用多少时间给枪装上一发子弹?
说明:假设一开始小明的枪中就有一发子弹,并且一旦确定一个装弹时间,小明始终会用这个时间完成子弹的装卸。希望你能帮助小明脱离险境。
输入格式
每组输入数据,第一行有两个整数n和m,(2≤n≤100,000; 1≤m≤10,000,000)n代表敌人个数,m代表小明的射程。
接下来有n行,每行一个整数mi,(1≤mi≤10,000,000),代表每个敌人一开始相对山头的距离(单位为米)。
输出格式
每组输出数据仅有一个整数,代表小明的换弹时间(单位为秒)。
样例输入
6 100
236
120
120
120
120
120
样例输出
25
#include<bits/stdc++.h>
using namespace std;
int mi[100003] = { 0 };
int mile[100003];
int n, m, ans = 0;
bool check(int mid) {
for (int i = 1; i <= n; i++)mile[i] = mi[i];
int wait = 0;
for (int i = 1; i <= n; i++) {
mile[i] -= wait;
int t = mile[i];
while (t > m) {
wait++;
t--;
}
if (mile[i] < 0)return false;
else {
wait += mid;
}
}
return true;
}
int main() {
cin >> n >> m;
for (int i = 1; i <= n; i++)cin >> mi[i];
sort(mi + 1, mi + n+1);
int left = 1, right = 1000000;
while (left <= right) {
int mid = (left + right) / 2;
if (check(mid)) {
left = mid + 1;
ans = max(ans, mid);
}
else right = mid - 1;
}
cout << ans;
return 0;
}
7-4 Reversing Linked List
Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K=3, then you must output 3→2→1→6→5→4; if K=4, you must output 4→3→2→1→5→6.
Input Specification:
Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤105) which is the total number of nodes, and a positive K (≤N) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.
Then N lines follow, each describes a node in the format:
Address Data Next
where Address
is the position of the node, Data
is an integer, and Next
is the position of the next node.
Output Specification:
For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.
Sample Input:
00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218
Sample Output:
00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1
#include<bits/stdc++.h>
using namespace std;
int main() {
int node, n,k, address;
cin >> node >> n >> k;
int data[100005], next[100005], valid[100005];
for (int i = 0; i < n; i++) {
cin >> address;
cin >> data[address] >> next[address];
}
int ans = 0;//不一定所有的输入的结点都是有用的,加个计数器
while (node != -1) {
valid[ans++] = node;
node = next[node];
}
for (int i = 0; i < (ans - ans % k); i += k)
reverse(begin(valid) + i, begin(valid) + i + k);
for (int i = 0; i < ans - 1; i++)
printf("%05d %d %05d\n", valid[i], data[valid[i]], valid[i + 1]);
printf("%05d %d -1", valid[ans - 1], data[valid[ans - 1]]);
return 0;
}
7-5 一元三次方程
给定一个形如ax3+bx2+cx+d=0的一元三次方程。
已知该方程有三个不同的实数根(根与根之差的绝对值≥10−6),且根范围均在[p,q]之间,你需要解出这个方程的三个根。
输入格式:
第一行一个整数T(1≤T≤1000),表示有T组数据
接下来T行,每行6个实数,分别表示a,b,c,d,p,q
数据保证:−102≤p,q≤102,且对于∀x∈[p,q],−106≤f(x)≤106
输出格式:
输出三个实数,表示方程的三个解。
你的答案可以以任意顺序输出。
一个答案被认为是正确的,当且仅当其与标准答案的绝对误差不超过10−6
输入样例:
在这里给出一组输入。例如:
1
1.000000 -5.000000 -4.000000 20.000000 -10.000000 10.000000
输出样例:
在这里给出相应的输出。例如:
-2.000000 2.000000 5.000000
提示1:
样例所给方程的图像如下:
提示2:
对于方程:ax2+bx+c=0(Δ=b2−4ac≥0),它的两个根分别为:x1=2a−b−Δ,x2=2a−b+Δ
#include<bits/stdc++.h>
using namespace std;
double a, b, c, d, p, q;
double eps = 1e-7;
double f(double x)
{
return a * x * x * x + b * x * x + c * x + d;
}
int main()
{
double left, right, mid, x1, x2;
int i, num;
cin >> num;
while (num--) {
cin >> a >> b >> c >> d >> p >> q;
int ans = 0;
for (i = p; i <= q; i++)
{
left = i;
right = i + 1;
x1 = f(left);
x2 = f(right);
if (!x1)
{
printf("%.2lf ", left);
ans++;
} //判断左端点,是零点直接输出。
//不能判断右端点,会重复。
if (x1 * x2 < 0) //区间内有根。
{
while (right - left >= eps) //二分控制精度。
{
mid = (left + right) / 2; //middle
if (f(mid) * f(right) <= 0)
left = mid;
else
right = mid; //计算中点处函数值缩小区间。
}
printf("%.6lf ", right);
//输出右端点。
ans++;
}
if (ans == 3)
break;
}
cout << endl;
}
return 0;
}