Linux新手在第一次安装Eclipse过程中出现JVM terminated. Exit code=1解决方法

小白新手第一天接触Linux ,在安装Eclipse 时,一直报错JVM terminated. Exit code=1,开始一直以为是环境变量配置错误,因为错误中第二排为JDK路径,之后也查询了网上很多种的解决方式,一直都没解决。

后来才发现,原来是因为自己的JDK是1.7的,而刚从Eclipse官网下载的Eclipse是最新版的,支持的JDK为1.8,所以导致错误

解决方法一:

更新jdk

我这里采用的是加载源的方式升级到最新的openjdk,指令如下

1、sudoadd-apt-repository ppa:openjdk-r/ppa

添加名为:openjdk-r 的源

2、sudoapt-get update

更新源

3、sudoapt-get install openjdk-8-jdk

安装 openjdk-8-jdk 

4、sudoupdate-alternatives --config java

查看并修改默认的Jdk

5、java-version

查看默认的Jdk是否修改成功



解决方法二:

下载以前的Eclipse版本


阅读更多
文章标签: eclipse linux jvm
个人分类: Linux下Java 开发
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页

关闭
关闭