OPJ-3349 SnowflakeSnowSnowflakes 解题报告(hash) 两片相同的雪花

链接- A -SnowflakeSnowSnowflakes

Time Limit:4000MS    Memory Limit:65536KB    64bit IO Format:%I64d & %I64u
 
Description

You may have heard that no two snowflakes are alike. Your task is to write a program to determine whether this is really true. Your program will read information about a collection of snowflakes, and search for a pair that may be identical. Each snowflake has six arms. For each snowflake, your program will be provided with a measurement of the length of each of the six arms. Any pair of snowflakes which have the same lengths of corresponding arms should be flagged by your program as possibly identical.

Input

The first line of input will contain a single integer n, 0 < n ≤ 100000, the number of snowflakes to follow. This will be followed byn lines, each describing a snowflake. Each snowflake will be described by a line containing six integers (each integer is at least 0 and less than 10000000), the lengths of the arms of the snow ake. The lengths of the arms will be given in order around the snowflake (either clockwise or counterclockwise), but they may begin with any of the six arms. For example, the same snowflake could be described as 1 2 3 4 5 6 or 4 3 2 1 6 5.

Output

If all of the snowflakes are distinct, your program should print the message:
No two snowflakes are alike.
If there is a pair of possibly identical snow akes, your program should print the message:
Twin snowflakes found.

Sample Input

2
1 2 3 4 5 6
4 3 2 1 6 5

Sample Output

Twin snowflakes found.

Hint

 

题目大意:输入N块雪花的六边的长度,若有两块雪花完全相同(顺时针或逆时针),即各边长度长度同,则输出存在两片完全相同的雪花。

 

#include<cstdio>
#include<algorithm>
#include<cstring>
const int HASH=99991;
const int MAXN=100000+5;
typedef int snow[6];
snow st[MAXN];
int head[HASH],next[MAXN];

int hash(snow& s)
{
	int i,v=0;
	for(i=0;i<6;i++)
		v=v+s[i];//printf("%d\n",v);
	return v%HASH;
}

bool compare(snow& s,snow& t)
{	
	int i;
	for(i=0;i<6;i++)
		if((s[i%6]==t[0]&&
			s[(i+1)%6]==t[1]&&
			s[(i+2)%6]==t[2]&&
			s[(i+3)%6]==t[3]&&
			s[(i+4)%6]==t[4]&&
			s[(i+5)%6]==t[5])||
			(s[i%6]==t[5]&&
			s[(i+1)%6]==t[4]&&
			s[(i+2)%6]==t[3]&&
			s[(i+3)%6]==t[2]&&
			s[(i+4)%6]==t[1]&&
			s[(i+5)%6]==t[0]))
			return true;
		return false;
}

bool search(int r)
{	
	int h=hash(st[r]);
	int u=head[h];
	while(u)
	{
		if(compare(st[u],st[r])) return true;
		u=next[u];
	}
	next[r]=head[h];
	head[h]=r;
	return false;
}

int main()
{
	int n,i,k=1;
	memset(head,0,sizeof(head));
	memset(next,0,sizeof(next));
	scanf("%d",&n);
	while(n--)
	{
		for(i=0;i<6;i++)
			scanf("%d",&st[k][i]);
		if(search(k)) { printf("Twin snowflakes found."); return 0;}
		k++;
	}
	printf("No two snowflakes are alike.");
	return 0;
}

 

答案解析:一个哈希函数,雪花各边总长%MAXHASH作为哈希值;

一个对比函数看有没有完全相同的两片雪花;

一个比较存储函数(next数组功能同散列表)。


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值