进阶题80 大整数相加

80 大整数相加

作者: xxx时间限制: 1S章节: 字符串

问题描述 :

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

输入说明 :

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

输出说明 :

For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

输入范例 :

2
1 2
112233445566778899 998877665544332211
输出范例 :

Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

解决思路:

1.两个数从个位开始相加 进位就到高位
2.注意格式输出 数组空间可以开大点(防止越界)
#include <stdio.h>
#include <string.h>
int main(){
	int T;
	scanf("%d", &T);
	
	int j,k;
	for (j = 1; j <= T; j++){
		char number1[1000];
		char number2[1000];
		int sum[1000] = {0};//置0
		//memset(sum, 0, sizeof(int));//int 类型怎么置0
		scanf("%s%s", number1, number2);
		int len1 = strlen(number1);
		int len2 = strlen(number2);
		int i;
		for (i = 0; i < len1 || i < len2; i++){
			if (i < len1)
				sum[i] += number1[len1 - i - 1] - '0';//字符转换为数字
			if (i < len2)
				sum[i] += number2[len2 - i - 1] - '0';
			if (sum[i] >= 10)
			{
				sum[i + 1] = sum[i] / 10;
				sum[i] = sum[i] % 10;
			}
		}
	
		printf("Case %d:\n", j);//格式输出
		for (k = 0; k<len1; k++)
			printf("%c", number1[k]);
		printf(" ");
		printf("+");
		printf(" ");
		for (k = 0; k<len2; k++)
			printf("%c", number2[k]);
		printf(" ");
		printf("=");
		printf(" ");
		if (len1 < len2)//判断谁最长
			len1 = len2;
		if (sum[i]>0)
			printf("%d", sum[i]);//最高位产生进位
		for (i = len1 - 1; i >= 0; i--)
			printf("%d", sum[i]);
		printf("\n\n");
	}
	return 0;
}

小结:
1.字符串处理大数加运算
2.字符转换为数字(不要犯错误)

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值