注册插件:违反了继承安全性规则,派生类型必须与基类型的安全性匹配或低于比基类型的安全可访问性低

当项目升级到VS2010或者2012 后(同时NET版本也升级到4.0),会出现如下错误提示信息:
类型“XXX”违反了继承安全性规则。派生类型必须与基类型的安全可访问性匹配或者比基类型的安全可访问性低。 

解决方法1:
其实很简单,在XXX项目中AssemblyInfo.cs文件里加上如下信息即可:
[assembly: System.Security.SecurityRules(System.Security.SecurityRuleSet.Level1)]

解决方法2:
通过新建一个类库生成AssemblyInfo.cs文件对比。发现
如果XXX项目中AssemblyInfo.cs文件里存在
[assembly: AllowPartiallyTrustedCallers]
把它删掉或者注释掉即可。
展开阅读全文

没有更多推荐了,返回首页