HDU 3346 Lucky Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3832    Accepted Submission(s): 1885

 

Problem Description

To Chinese people, 8 is a lucky number. Now your task is to judge if a number is lucky.
We say a number is lucky if it’s a multiple of 8, or the sum of digits that make up the number is a multiple of 8, or the sum of every digit’s square is a multiple of 8.

 

Input

The first line contains an integer stands for the number of test cases.
Each test case contains an integer n (n >= 0).

 

Output

For each case, output “Lucky number!” if the number is lucky, otherwise output “What a pity!”.

 

Sample Input

2

0

8

 

 

Sample Output

Lucky number!

Lucky number!

 

Author

dandelion

 

Source

HDU2010省赛集训队选拔赛(校内赛)

 

Recommend

lcy

题记:

题目的意思是:

如果一个数字是8的倍数,或数字的总和构成数字是8的倍数,或每个数字的平方的总和是8的倍数,那就称这个数是幸运数字,即Lucky number。

t组数据,每组输入一个数字,判断是否是幸运数字,是就输出“Lucky number!”,不是就输出“What a pity!”。

 

C++程序如下:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

int sum1(int n){
	int s=0;
	while(n){
		s += n%10;
		n /= 10;
	}
	return s;
}

int sum2(int n){
	int s=0;
	while(n){
		s += (n%10)*(n%10);
		n /= 10;
	}
	return s;
}

int main(void){
	int t;
	cin >> t;
	while(t--){
		int n;
	    cin >> n;
	    
	    if(n%8==0 || sum1(n)%8==0 || sum2(n)%8==0)
	        cout << "Lucky number!" << endl;
	    else 
	        cout << "What a pity!" << endl;
	    
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值