HDU 2612 Find a way

Find a way

Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)


Problem Description
Pass a year learning in Hangzhou, yifenfei arrival hometown Ningbo at finally. Leave Ningbo one year, yifenfei have many people to meet. Especially a good friend Merceki.
Yifenfei’s home is at the countryside, but Merceki’s home is in the center of city. So yifenfei made arrangements with Merceki to meet at a KFC. There are many KFC in Ningbo, they want to choose one that let the total time to it be most smallest.
Now give you a Ningbo map, Both yifenfei and Merceki can move up, down ,left, right to the adjacent road by cost 11 minutes.


Input
The input contains multiple test cases.
Each test case include, first two integers n, m. (2<=n,m<=200).
Next n lines, each line included m character.
‘Y’ express yifenfei initial position.
‘M’ express Merceki initial position.
‘#’ forbid road;
‘.’ Road.
‘@’ KCF


Output
For each test case output the minimum total time that both yifenfei and Merceki to arrival one of KFC.You may sure there is always have a KFC that can let them meet.


Sample Input
4 4
Y.#@
....
.#..
@..M
4 4
Y.#@
....
.#..
@#.M
5 5
Y..@.
.#...
.#...
@..M.
#...#


Sample Output
66
88
66


Author
yifenfei


Source

奋斗的年代


这几天忙学习... 找了些题保持手感。

思路:2次BFS 得到Y、M 到@的最短距离 

ps :测了下杭电没给Y、M不能互走,或者互走影响结果的数据,注意一点,可能KFC周围都是墙。

有几个细节可以优化,我这没加工。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
#define min(a,b) (a>b?b:a)
#define CLR(arr,x) memset(arr,x,sizeof(arr))
using namespace std;
const int maxn = 400 ;
const int inf = 1<<30 ;
char mapp[maxn][maxn] ;
int ans1[maxn][maxn] , ans2[maxn][maxn] ;
bool step[maxn][maxn] ;
int Next[4][2] = { {0,1} , {1,0} , {0,-1} ,{-1,0} } ;
int n , m ;
struct point{
    int row , col ;
};
point st , st2 ;
void init() {
    CLR(ans1,0) ;
    CLR(ans2,0) ;
    CLR(mapp,0) ;
}
bool judge(point init) {
    if( init.row>=0&&init.row<n && init.col>=0 && init.col < m ) {
        return true ;
    }
    return false;
}
void bfs(point temp) {
    queue<point> V ;
    while(!V.empty()){
        V.pop() ;
    }
    V.push(temp) ;
    CLR(step,0) ;
    step[temp.row][temp.col] = true ;
    point init ;
    while(!V.empty()) {
        temp = V.front() ;
        V.pop() ;
        for( int i = 0 ; i < 4 ; ++i) {
            init.row = temp.row+Next[i][0] ;
            init.col = temp.col+Next[i][1] ;
            if( judge(init) && !step[init.row][init.col] ){
                if(  mapp[init.row][init.col] != '#'   ) {
                    ans1[init.row][init.col] = ans1[temp.row][temp.col]+1 ;
                    step[init.row][init.col] = true ;
                    V.push(init) ;
                }
            }
        }
    }
}
void bfs2(point temp) {
    queue<point> V2 ;
    while(!V2.empty()){
        V2.pop() ;
    }
    V2.push(temp) ;
    CLR(step,0) ;
    step[temp.row][temp.col] = true ;
    point init ;
    while(!V2.empty()) {
        temp = V2.front() ;
        V2.pop() ;
        for( int i = 0 ; i < 4 ; ++i) {
            init.row = temp.row+Next[i][0] ;
            init.col = temp.col+Next[i][1] ;
            if( judge(init) && !step[init.row][init.col] ){
                if( mapp[init.row][init.col] != '#' ) {
                    ans2[init.row][init.col] = ans2[temp.row][temp.col]+1 ;
                    V2.push(init) ;
                    step[init.row][init.col] = true ;
                }
            }
        }
    }
}
int main() {
    while(~scanf("%d%d",&n,&m)) {
            init() ;
        for( int i = 0 ; i < n ; ++i ){
                scanf("%s",mapp[i]) ;
            for( int j = 0 ; j < m ; ++j ){
                    if( mapp[i][j] == 'Y') {
                        st.row = i ;
                        st.col = j ;
                    }
                    if(mapp[i][j] == 'M') {
                        st2.row = i ;
                        st2.col = j ;
                    }
            }
        }
        bfs(st) ;
        bfs2(st2) ;
        int minn = inf ;
        for( int i = 0 ;i < n ; ++i ) {
            for( int j = 0 ;j  < m ; ++j ){
               if(mapp[i][j] == '@' && ans1[i][j] && ans2[i][j] ) {
                minn = min(minn,ans1[i][j]+ans2[i][j]) ;
               }
            }
        }
        printf("%d\n",minn*11) ;
    }
    return 0 ;
}


  

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值