PAT (Advanced Level) Practice 1020

127 篇文章 0 订阅
119 篇文章 0 订阅

1020. Tree Traversals (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7
Sample Output:
4 1 6 3 5 7 2

分析:题目大意:首先输入二叉树节点个数,接着输入二叉树的后序与中序遍历顺序。输出为层序遍历顺序。

这里需要一个通过后序遍历与先序遍历顺序重构出二叉树的算法,思路为:后序遍历的最后一个节点为根节点,而中序遍历时根节点在序列中间。找出这个根节点,以此为界划分出中序遍历中的左右序列,然后采用递归的手法分别处理左右序列。

层序遍历顺序通过队列实现,类似BFS的思想。将节点入队,取值,之后将左右子树(若存在)入队,重复上述过程直至队空。

代码:

#include<iostream>
#include<queue>
#define MAX 30
using namespace std;
struct bitree{
	int data;
	bitree *left;
	bitree *right;
};
int in[MAX] = {0}, post[MAX] = {0};
int layer[MAX] = {0};
int cnt;
bitree *creat(int inL, int inR, int postL, int postR)
{
	if(postL > postR){
		return NULL;
	}
	bitree *root = new bitree;
	root->data = post[postR];
	int i;
	for(i = inL; i <= inR; i++){
		if(in[i] == post[postR]){
			break;
		}
	}
	int numL = i - inL;
	root->left = creat(inL, i - 1, postL, postL + numL - 1);
	root->right = creat(i + 1, inR, postL + numL, postR - 1);
	return root;
}
void layerorder(bitree *root)
{
	queue<bitree *> q;
	q.push(root);
	while(!q.empty()){
		bitree *top = q.front();
		q.pop();
		layer[cnt++] = top->data;
		if(top->left != NULL){
			q.push(top->left);
		}
		if(top->right != NULL){
			q.push(top->right);
		}
	}
}
int main()
{
	int n;
	cin >> n;
	for(int i = 0; i < n; i++){
		cin >> post[i];
	}
	for(int i = 0; i < n; i++){
		cin >> in[i];
	}
	bitree *root = creat(0, n - 1, 0, n - 1);
	layerorder(root);
	for(int i = 0; i < cnt; i++){
		if(i != cnt - 1){
			cout << layer[i] << ' ';
		}else{
			cout << layer[i] << endl;
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值