PAT (Advanced Level) Practice 1030(Dijkstra)

127 篇文章 0 订阅
119 篇文章 0 订阅

1030 Travel Plan (30 分)

A traveler's map gives the distances between cities along the highways, together with the cost of each highway. Now you are supposed to write a program to help a traveler to decide the shortest path between his/her starting city and the destination. If such a shortest path is not unique, you are supposed to output the one with the minimum cost, which is guaranteed to be unique.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 4 positive integers N, M, S, and D, where N (≤500) is the number of cities (and hence the cities are numbered from 0 to N−1); M is the number of highways; S and D are the starting and the destination cities, respectively. Then M lines follow, each provides the information of a highway, in the format:

City1 City2 Distance Cost

where the numbers are all integers no more than 500, and are separated by a space.

Output Specification:

For each test case, print in one line the cities along the shortest path from the starting point to the destination, followed by the total distance and the total cost of the path. The numbers must be separated by a space and there must be no extra space at the end of output.

Sample Input:

4 5 0 3
0 1 1 20
1 3 2 30
0 3 4 10
0 2 2 20
2 3 1 20

Sample Output:

0 2 3 3 40

分析:直接用Dijkstra来计算最短路径,用一个pre数组储存最短路径。因为第二标尺简单易算,这里将第二标尺的判定与Dijkstra的判定同步进行。

代码: 

#include<iostream>
#include<algorithm>
#define MAXN 501
#define INF 0x3fffffff
using namespace std;
int N, M, S, D;
int G[MAXN][MAXN];
int C[MAXN][MAXN];
int d[MAXN];
int c[MAXN];
int pre[MAXN];
int visit[MAXN] = { 0 };
void dfs(int v) {
	if (v == S) {
		cout << v << ' ';
		return;
	}
	dfs(pre[v]);
	cout << v << ' ';
}
void dijkstra(int start) {
	d[start] = 0;
	c[start] = 0;
	for (int i = 0; i < N; i++) {
		pre[i] = i;
	}
	for (int i = 0; i < N; i++) {
		int u = -1, minN = INF;
		for (int j = 0; j < N; j++) {
			if (visit[j] == 0 && d[j] < minN) {
				u = j;
				minN = d[j];
			}
		}
		if (u == -1) {
			return;
		}
		visit[u] = 1;
		for (int v = 0; v < N; v++) {
			if (G[u][v] != INF && visit[v] == 0) {
				if (d[v] > d[u] + G[u][v]) {
					d[v] = d[u] + G[u][v];
					c[v] = c[u] + C[u][v];
					pre[v] = u;
				}else if(d[v] == d[u] + G[u][v]){
					if (c[v] > c[u] + C[u][v]) {
						c[v] = c[u] + C[u][v];
						pre[v] = u;
					}
				}
			}
		}
	}
}
int main() {
	fill(G[0], G[0] + MAXN * MAXN, INF);
	fill(d, d + MAXN, INF);
	fill(c, c + MAXN, 0);
	cin >> N >> M >> S >> D;
	for (int i = 0; i < M; i++) {
		int c1, c2, d, c;
		cin >> c1 >> c2 >> d >> c;
		G[c1][c2] = G[c2][c1] = d;
		C[c1][c2] = C[c2][c1] = c;
	}
	dijkstra(S);
	dfs(D);
	cout << d[D] << ' ' << c[D] << endl;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值