A - Oil Deposits (深度搜索)

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input

The input contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.
 

Output

are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5 
****@
*@@*@
*@**@
@@@*@
@@**@
0 0

Sample Output

0
1
2
2

 

 

 

本题的题目是说有多少个孤立的油田 大体就是这个意思

思路  :

用的是深度搜索  我觉得关键的处理的地方在于

 

c++代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>                                                        
using namespace std;
int n,m;
int ans;
char oil[105][105];
int digit[8][2]={{-1,-1},{-1,0},{-1,1},{0,-1},{0,1},{1,-1},{1,0},{1,1}};//这八个地方都要遍历一下
bool dfs(int x,int y)
{
    int i;
    oil[x][y]='*';//我觉得 这是这个深度搜索最最最最关键的地方
    int tx,ty;
    for(i=0;i<8;i++)
    {
    tx=x+digit[i][0];
    ty=y+digit[i][1];
    if(tx>-1&&tx<n&&ty>-1&&ty<m)
    {
            if(oil[tx][ty]=='@')
         dfs(tx,ty);
    }
    }
}
int main()
{
    while(scanf("%d%d",&n,&m)!=EOF)
    {
    if(n==0&&m==0)break;
    int i,j;
    for(i=0;i<n;i++)
    {
        scanf("%s",oil[i]);
        getchar();
    }   //输入控制完成;
    ans=0;
    for(i=0;i<n;i++)
    {
        for(j=0;j<m;j++)
        {
            if(oil[i][j]=='@')
          {
                  dfs(i,j);
                ans++;
          }
        }
    }
    printf("%d\n",ans);
    }
    return 0;
}

 

  • 1
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值