G - Ordering Tasks(拓补排序)

G - Ordering Tasks

题目:

John has n tasks to do. Unfortunately, the tasks are not independent and the execution of one task is only possible if other tasks have already been executed.


Input

The input will consist of several instances of the problem. Each instance begins with a line containing two integers, 1 <= n <= 100 and mn is the number of tasks (numbered from 1 to n) and m is the number of direct precedence relations between tasks. After this, there will be m lines with two integers i and j, representing the fact that task i must be executed before task j. An instance with n = m = 0 will finish the input.

Output

For each instance, print a line with n integers representing the tasks in a possible order of execution.

Sample Input

5 4
1 2
2 3
1 3
1 5
0 0

Sample Output

1 4 2 5 3


题目大意:

约翰有n个任务要做, 不幸的是,这些任务并不是独立的,执行某个任务之前要先执行完其他相关联的任务。



c++代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
#include<vector>
#include<algorithm>
using namespace std;
int n,m;
int one[105];
int two[105];
int degree[105]; 
int book[105];//表示他们都没有输出 
int main()
{
   while(scanf("%d%d",&n,&m)!=EOF)
   {
   	   if(n==0&&m==0) break;
   	   memset(degree,0,sizeof(degree));
   	   memset(book,0,sizeof(book));
   	   int i,j;
   	   int x,y;
   	   for(i=1;i<=m;i++)
   	   {
   	   	scanf("%d%d",&x,&y);
   	   	degree[y]++;
   	   	one[i]=x;
   	   	two[i]=y; 
   	   }
   	   int k=0;
   	   int flag;
   	   for(int i = 1;; i=(i+1)%n)
   	{
   		if(i==0)i=n;
   		flag=0;
   	   	if(degree[i]==0&&book[i]==0)
	   {
   	   	  book[i]=1;
   	   	  flag=1;
   	   	  for(int j=1;j<=m;j++)
   	   	  {
   	   	    if(one[j]==i)
		    degree[two[j]]--;	
   	   	  } 
   	   } 
   	   if(flag)
   	   {
   	   	    k++;
   	   	    if(k<n)printf("%d ",i);
   	   	    else if(k==n)
		    {
		    	printf("%d\n",i);
		     	break;	 
		    } 	
   	   }
   	 }
   }
	return 0;
} 




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值