C - Just a Hook(线段树)(区间一般更新以及求总和释放懒惰标记)

C - Just a Hook

In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.



Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.

Input The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.
Output For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.
Sample Input
1
10
2
1 5 2
5 9 3
Sample Output
Case 1: The total value of the hook is 24.
题目的意思 就是 。。。。1----10  都是1  后来区间更新了1--5是2 再次区间更新5--9是3

求总和就是这个意思


代码:
#include<iostream>
#include<map>
#include<algorithm>
#include<cstdio>
#include<cstring>
using namespace std;
const int N=100000*4;
struct node
{
	int l,r;
	int lazy;
	node(){lazy = 1;}//初始化为1 
}tree[N];
void build(int k,int l,int r)
{
	tree[k].l=l; tree[k].r=r;
	tree[k].lazy=1; 
	if(l==r)return;
	int mid=(l+r)>>1;
	build(k<<1,l,mid);
	build(k<<1|1,mid+1,r);
	return;
}
void pushlazy(int k)
{
	tree[k<<1].lazy=tree[k<<1|1].lazy=tree[k].lazy;
	tree[k].lazy=-1;//释放懒惰标记 
	return;
}
void charge(int k,int ll,int rr,int val)
{
	if(ll<=tree[k].l&&rr>=tree[k].r)
	{
		tree[k].lazy=val;
		return ;
	}
	if(tree[k].lazy!=-1)
		pushlazy(k);
	int mid=(tree[k].l+tree[k].r)>>1;
	if(rr<=mid) charge(k<<1,ll,rr,val);
	else if(ll>mid) charge(k<<1|1,ll,rr,val);
	else 
	{
		charge(k<<1,ll,mid,val);
		charge(k<<1|1,mid+1,rr,val);
	}
}
int find(int k)
{
	if(tree[k].lazy!=-1)
	{
		return (tree[k].r-tree[k].l+1)*tree[k].lazy; 
	}//递归出口 
	else 
	return find(k<<1)+find(k<<1|1);
}
int main()
{
	int t;cin>>t;int casee=0;
	while(t--)
	{
		int n,m,x,y,z;
		scanf("%d%d",&n,&m);
		build(1,1,n);
		while(m--)
		{
			scanf("%d%d%d",&x,&y,&z);
			charge(1,x,y,z);
		}
	//	for(int k=1;k<=30;k++)
	//	printf("%d %d %d\n",tree[k].l,tree[k].r,tree[k].lazy);
		printf("Case %d: The total value of the hook is %d.\n",++casee,find(1));
	}
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值