F - Prime Path POJ - 3126(广搜)


The ministers of the cabinet were quite upset by the message from the Chief of Security stating that they would all have to change the four-digit room numbers on their offices.
— It is a matter of security to change such things every now and then, to keep the enemy in the dark.
— But look, I have chosen my number 1033 for good reasons. I am the Prime minister, you know!
— I know, so therefore your new number 8179 is also a prime. You will just have to paste four new digits over the four old ones on your office door.
— No, it’s not that simple. Suppose that I change the first digit to an 8, then the number will read 8033 which is not a prime!
— I see, being the prime minister you cannot stand having a non-prime number on your door even for a few seconds.
— Correct! So I must invent a scheme for going from 1033 to 8179 by a path of prime numbers where only one digit is changed from one prime to the next prime.

Now, the minister of finance, who had been eavesdropping, intervened.
— No unnecessary expenditure, please! I happen to know that the price of a digit is one pound.
— Hmm, in that case I need a computer program to minimize the cost. You don't know some very cheap software gurus, do you?
— In fact, I do. You see, there is this programming contest going on... Help the prime minister to find the cheapest prime path between any two given four-digit primes! The first digit must be nonzero, of course. Here is a solution in the case above.

1033
1733
3733
3739
3779
8779
8179
The cost of this solution is 6 pounds. Note that the digit 1 which got pasted over in step 2 can not be reused in the last step – a new 1 must be purchased.

Input
One line with a positive number: the number of test cases (at most 100). Then for each test case, one line with two numbers separated by a blank. Both numbers are four-digit primes (without leading zeros).
Output
One line for each case, either with a number stating the minimal cost or containing the word Impossible.
Sample Input
3
1033 8179
1373 8017
1033 1033
Sample Output
6
7
0

这题..题目的意思就是从一个质数变成另一个质数中途变换的过程必须全部是质数求  变换的最小的次数

这题解题目的思路就是首先 先将1000---9999的表打出来 之后再BFS();算挺简单的吧中途操作变换下就行

其实 这个题目以前集训队的做过了  但是那个时候怎么都做不出来

现在想想确实很简单。。。。

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
#include<cmath>
using namespace std;
int beginn,endd;
const int maxn=10005;
int book[maxn];
int prime[maxn]; 
struct node
{
	int digit;
	int s;
};
void init()
{
	memset(prime,0,sizeof(prime));
	for(int i=1000;i<=9999;i++)
	{
		for(int j=2;j<=sqrt(i);j++)
		{
			if(i%j==0)
			{
				prime[i]=1;
				break;
			}
		}
	}
}//1表示不是质数 
void BFS(int x,int y)
{
	node a={x,0};
	queue<node>qu;
	while(qu.empty()==0)qu.pop();
	qu.push(a);//把a扔进去
	book[x]=1;
	while(qu.empty()==0)
	{
		node tmp=qu.front();
		qu.pop();
		int k,l,r;
		node t;
		//千位 
		for(int i=1;i<=9;i++)
		{
			k=i*1000+tmp.digit%1000;
		
			if(book[k]==0&&prime[k]==0){
				t.digit=k;
				t.s=tmp.s+1;
				book[k]=1; 
				if(t.digit==y){
					printf("%d\n",t.s);
					return;
				}
				qu.push(t);
			}
		} 
		//百位 
		for(int i=0;i<=9;i++)
		{
			k=(tmp.digit/1000)*1000+i*100+tmp.digit%100;
			if(book[k]==0&&prime[k]==0){
				t.digit=k;
				t.s=tmp.s+1;
				book[k]=1; 
				if(t.digit==y){
					printf("%d\n",t.s);
					return;
				}
				qu.push(t);
			}
		}
		//十位 
		for(int i=0;i<=9;i++)
		{
			k=(tmp.digit/100)*100+i*10+tmp.digit%10;
		
			if(book[k]==0&&prime[k]==0){
				t.digit=k;
				t.s=tmp.s+1;
				book[k]=1; 
				if(t.digit==y){
					printf("%d\n",t.s);
					return;
				}
				qu.push(t);
			}
		}
		//个位 
		for(int i=0;i<=9;i++)
		{
			k=(tmp.digit/10)*10+i; 
		
			if(book[k]==0&&prime[k]==0){
				t.digit=k;
				t.s=tmp.s+1;
				book[k]=1; 
				if(t.digit==y){
					printf("%d\n",t.s);
					return;
				}
				qu.push(t);
			}
		}	
	} 
}
int main()
{
	init();//先打表把1000---9999中的质数打出来 
	int n ;
	scanf("%d",&n);
	while(n--)
	{
		scanf("%d%d",&beginn,&endd);
		if(beginn==endd){
			printf("0\n");
			continue;
		}
		memset(book,0,sizeof(book));
		BFS(beginn,endd);
	} 
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值