1136 A Delayed Palindrome(20 分)

Consider a positive integer N written in standard notation with k+1 digits a​i​​ as a​k​​⋯a​1​​a​0​​ with 0≤a​i​​<10 for all i and a​k​​>0. Then N is palindromic if and only if a​i​​=a​k−i​​ for all i. Zero is written 0 and is also palindromic by definition.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. Such number is called a delayed palindrome. (Quoted from https://en.wikipedia.org/wiki/Palindromic_number )

Given any positive integer, you are supposed to find its paired palindromic number.

Input Specification:

Each input file contains one test case which gives a positive integer no more than 1000 digits.

Output Specification:

For each test case, print line by line the process of finding the palindromic number. The format of each line is the following:

A + B = C

where A is the original number, B is the reversed A, and C is their sum. A starts being the input number, and this process ends until C becomes a palindromic number -- in this case we print in the last line C is a palindromic number.; or if a palindromic number cannot be found in 10 iterations, print Not found in 10 iterations. instead.

Sample Input 1:

97152

Sample Output 1:

97152 + 25179 = 122331
122331 + 133221 = 255552
255552 is a palindromic number.

Sample Input 2:

196

Sample Output 2:

196 + 691 = 887
887 + 788 = 1675
1675 + 5761 = 7436
7436 + 6347 = 13783
13783 + 38731 = 52514
52514 + 41525 = 94039
94039 + 93049 = 187088
187088 + 880781 = 1067869
1067869 + 9687601 = 10755470
10755470 + 07455701 = 18211171
Not found in 10 iterations.

emmmmm  因为最多10次 所以所一个字符一个字符的弄也不会超时  我是这么写的

其中要注意的测试点就是 如果说输入的本身就是回文的话 那么就是了 直接输出这个数是回文了

代码:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<vector>
int one[1500],three[1500],len;
using namespace std; 
bool IsPalindromic()//是从1开始的 
{
	int i=1,j = len;
	while(i <= j)
	{
		if(one[i] == one[j])
			i++,j--;
		else 
			return false;	
	}
	return true;
}
int main()
{
	char s[1500];
	scanf("%s",s+1);
	len =strlen(s+1);
	for(int i=1;i<=len;i++)
		one[i]= s[i]-'0';  //把这些东西都放到one这个数组里面因为是数字 
	if(IsPalindromic())
	{
		for(int i =1;i<=len;i++)
			printf("%d",one[i]);
		printf(" is a palindromic number.\n");
		return 0;
	}
	for(int p=1;p<=10;p++)
	{
		for(int i = len; i >= 1;i--)	
		{
			three[i] = three[i] + one[i] + one[len+1-i];
			three[i-1] = three[i-1] + three[i]/10;
			three[i] = three[i]%10;	
		} 
		
		for(int i=1;i <= len;i++)
			printf("%d",one[i]);
		printf(" + ");
		for(int i=len;i >=1;i--)
			printf("%d",one[i]); 
		printf(" = ");
		if(three[0] != 0 ){
			for(int i = len;i>=0;i--)
				three[i+1] = three[i];//移动 
			len++; 
		}
		for(int i=1;i<=len;i++) 
		{
			one[i] = three[i];
			printf("%d",three[i]);
			three[i] = 0;
		}	
		three[0] = 0 ;
		printf("\n"); 
		if(IsPalindromic())
		{
			for(int i =1;i<=len;i++)
				printf("%d",one[i]);
			printf(" is a palindromic number.\n");
			return 0;
		}
	} 
	cout<<"Not found in 10 iterations."<<endl; 
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值