1138 Postorder Traversal(25 分)
Suppose that all the keys in a binary tree are distinct positive integers. Given the preorder and inorder traversal sequences, you are supposed to output the first number of the postorder traversal sequence of the corresponding binary tree.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 50,000), the total number of nodes in the binary tree. The second line gives the preorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print in one line the first number of the postorder traversal sequence of the corresponding binary tree.
Sample Input:
7
1 2 3 4 5 6 7
2 3 1 5 4 7 6
Sample Output:
3
给出先序和中序 求出后序的第一个元素
先建立二叉树然后输出
其中有个问题就是 如果不是使用引用的话 在main里面定义的pre和in 会内存超限 在栈里面嗯。。。涨知识了
#include<bits/stdc++.h>
using namespace std;
vector<int>post;
struct node
{
int val;
node *left;
node *right;
};
node* CreatTree(vector<int>&pre,vector<int>&in,int pl,int pr,int il,int ir)
{
if(pl > pr )return NULL;
node *root = (node*)malloc(sizeof(node));
root->val = pre[pl];
root->left = NULL;
root->right = NULL;
int pos;
for(int i = il; i<= ir ;i++)
{
if (pre[pl] == in[i])
{
pos = i;
break;
}
}
root->left = CreatTree(pre,in,pl+1,pos-il+pl,il,pos-1) ;
root->right = CreatTree(pre,in,pos-il+pl+1,pr,pos+1,ir) ;
return root;
}
void postorder(node *root)
{
if(root)
{
postorder(root->left);
postorder(root->right);
post.push_back(root->val);
}
}
int main()
{
int n,num;
scanf("%d",&n);
vector<int>pre,in;
for(int i = 0; i < n; i++)
{
scanf("%d",&num);
pre.push_back(num);
}
for(int i = 0; i < n; i++)
{
scanf("%d",&num);
in.push_back(num);
}
node *root = CreatTree(pre,in,0,n-1,0,n-1);
postorder(root);
printf("%d\n",post[0]);
return 0;
}