1139 First Contact(30 分)

1139 First Contact(30 分)

Unlike in nowadays, the way that boys and girls expressing their feelings of love was quite subtle in the early years. When a boy A had a crush on a girl B, he would usually not contact her directly in the first place. Instead, he might ask another boy C, one of his close friends, to ask another girl D, who was a friend of both B and C, to send a message to B -- quite a long shot, isn't it? Girls would do analogously.

Here given a network of friendship relations, you are supposed to help a boy or a girl to list all their friends who can possibly help them making the first contact.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (1 < N ≤ 300) and M, being the total number of people and the number of friendship relations, respectively. Then M lines follow, each gives a pair of friends. Here a person is represented by a 4-digit ID. To tell their genders, we use a negative sign to represent girls.

After the relations, a positive integer K (≤ 100) is given, which is the number of queries. Then K lines of queries follow, each gives a pair of lovers, separated by a space. It is assumed that the first one is having a crush on the second one.

Output Specification:

For each query, first print in a line the number of different pairs of friends they can find to help them, then in each line print the IDs of a pair of friends.

If the lovers A and B are of opposite genders, you must first print the friend of A who is of the same gender of A, then the friend of B, who is of the same gender of B. If they are of the same gender, then both friends must be in the same gender as theirs. It is guaranteed that each person has only one gender.

The friends must be printed in non-decreasing order of the first IDs, and for the same first ones, in increasing order of the seconds ones.

Sample Input:

10 18
-2001 1001
-2002 -2001
1004 1001
-2004 -2001
-2003 1005
1005 -2001
1001 -2003
1002 1001
1002 -2004
-2004 1001
1003 -2002
-2003 1003
1004 -2002
-2001 -2003
1001 1003
1003 -2001
1002 -2001
-2002 -2003
5
1001 -2001
-2003 1001
1005 -2001
-2002 -2004
1111 -2003

Sample Output:

4
1002 2004
1003 2002
1003 2003
1004 2002
4
2001 1002
2001 1003
2002 1003
2002 1004
0
1
2003 2001
0

先说下题目意思吧:

就是A想要追求B 需要通过C和D

要求是 A认识C      D认识 B和C   AC相同性别  BD相同性别  就是这个..........

第一个测试点是样例

第二三个测试点是处理跟0相关的   有-0000和0000 需要处理下 我遇到这两种情况直接变成55555和-55555

第四五个测试点是 他们四个人都是不一样的 就是找的这四个人都是不同的

第六个测试点 我出现段错误因为可能有很多对朋友可以帮他们  结构体数组开大就可以了

做法是A在自己认识的同性中找C B在自己认识的同性中找D 判断一下C和D是否认识行了

然后还有 输出按第一个id的非递减 第一个id相同则按第二个id的递增 用%04d输出

我昨晚了做了一直没找出自己错哪里  后来发现...............0000这块没处理好 小毛病

 

代码:

#include<bits/stdc++.h>
using namespace std;
map<int,vector<int> >mp;
int a,b,x,y;
struct node
{
	int one,two;
};
bool cmp(node a,node b){
	if(a.one != b.one)
		return a.one < b.one;
	return a.two < b.two;
}
void change(char s1[], char s2[])
{
		a = atoi(s1);
		b = atoi(s2);
		if (strcmp(s1,"0000") == 0) a = 55555;
		if (strcmp(s1,"-0000") == 0) a = -55555;
		if (strcmp(s2,"0000") == 0) b = 55555;	 
		if (strcmp(s2,"-0000") == 0) b = -55555;
		return ;
}
int main()
{
	int n,m;
	char  s1[10],s2[10];
	scanf("%d%d",&n,&m);
	for(int i = 1;i <= m; i++)
	{
		cin>>s1>>s2;
		change(s1,s2);
		mp[a].push_back(b);
		mp[b].push_back(a);
	}
	int k;
	scanf("%d",&k);
	for(int i = 0; i < k; i++)
	{
		cin>>s1>>s2;
		change(s1,s2);
		node gg[15000];
		int now = 0,op;
		for(int i = 0; i < mp[a].size(); i++)
		{
			int c = mp[a][i];
			if(a * c > 0 && b != c && a != c) //找到和a同性别的c 并且 c和 b不是同一个 
			{
				for(int j = 0 ; j<mp[b].size();j++)
				{
					int d = mp[b][j];
					if(b * d > 0 && d != c && d != a && d != b )//找到和b同性别的  
					{
						//判断 c是否认识mp[b][j];
						if(count(mp[c].begin(),mp[c].end(),d )  > 0)  
						{
							if(c == 55555 || c == -55555)c = 0;
							if(d == 55555 || d == -55555)d = 0;
							gg[++now].one = abs(c);
							gg[now].two = abs(d);
						}
					}	
				} 
			}
		}
		printf("%d\n",now);
		sort(gg+1,gg+1+now,cmp);
		for(int i = 1; i<= now; i++)
			printf("%04d %04d\n",gg[i].one,gg[i].two);
	}
	return 0;
}

 

 

 

  • 3
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 11
    评论
如果你想在 Dynamics CRM 中使用 LinkEntity 来获取第一个订单,可以修改上面代码来包含 LinkEntity: ```csharp var query = new QueryExpression("salesorder"); query.ColumnSet = new ColumnSet(true); query.AddOrder("createdon", OrderType.Ascending); query.PageInfo = new PagingInfo { Count = 1, PageNumber = 1 }; var link = query.AddLink("contact", "customerid", "contactid"); link.EntityAlias = "contact"; link.Columns.AddColumns("fullname", "emailaddress1"); var result = service.RetrieveMultiple(query); if (result.Entities.Count > 0) { var firstOrder = result.Entities[0]; var customer = firstOrder.GetAttributeValue<EntityReference>("customerid"); var contact = firstOrder.GetAttributeValue<EntityCollection>("contact"); } ``` 这个代码创建了一个名为 "salesorder" 的 QueryExpression 对象,并使用 AddLink 方法将 "contact" 实体链接到 "salesorder" 实体。链接条件是 "customerid" 属性相等。然后,使用 EntityAlias 属性设置实体别名,并使用 AddColumns 方法设置需要检索的列集合。 最后,使用 RetrieveMultiple 方法执行查询,并检查结果是否包含实体。如果有实体,可以使用 GetAttributeValue 方法从实体中检索属性值,包括链接实体中的属性。在这个例子中,我们将 "customerid" 属性配给 customer 变量,将链接实体 "contact" 配给 contact 变量。 请注意,这里仅返回第一个订单及其链接实体的第一个元素。如果需要检索更多订单或链接实体,请修改 PageInfo 对象的 Count 和 PageNumber 属性。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 11
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值