1073 Scientific Notation (20)(20 分)

1073 Scientific Notation (20)(20 分)

Scientific notation is the way that scientists easily handle very large numbers or very small numbers. The notation matches the regular expression [+-][1-9]"."[0-9]+E[+-][0-9]+ which means that the integer portion has exactly one digit, there is at least one digit in the fractional portion, and the number and its exponent's signs are always provided even when they are positive.

Now given a real number A in scientific notation, you are supposed to print A in the conventional notation while keeping all the significant figures.

Input Specification:

Each input file contains one test case. For each case, there is one line containing the real number A in scientific notation. The number is no more than 9999 bytes in length and the exponent's absolute value is no more than 9999.

Output Specification:

For each test case, print in one line the input number A in the conventional notation, with all the significant figures kept, including trailing zeros,

Sample Input 1:

+1.23400E-03

Sample Output 1:

0.00123400

Sample Input 2:

-1.2E+10

Sample Output 2:

-12000000000

 

不得不数..pat真的对Java很不友好啊

Java代码全部超时.......

代码如下

import java.util.Scanner;
import java.util.Vector;
import java.math.BigInteger; //Java的 大数类在math类中  
import java.math.BigDecimal;
public class P1147 {
	static Scanner  sc = new Scanner(System.in);
	public static void main(String[] args) {
		String a;
		a = sc.next();
		int op = -1;
			BigDecimal db = new BigDecimal(a);
			System.out.println(db.toPlainString()); 
	//	System.out.println("科学计数:" + db.toString());
		 
	//	System.out.println("普通计数:" + db.toPlainString());
		sc.close();
	}
}

 

C++代码: 转载来自:https://blog.csdn.net/qq_31474267/article/details/79256175

#include<bits/stdc++.h> 
using namespace std;
int main() {
    string s, sc, se;
    cin >> s;
    for (int i = 0; i < s.length(); i++) {
        if (s[i] == 'E') {
            sc = s.substr(0, i);//前面的转化在sc上 
            se = s.substr(i+1, s.length()); //后面的转化在se上想法一样实现的比我好多了 
            break;
        }
    }
    
    char fc = sc[0], fe = se[0];//记录下他们的符号 
    int n = stoi(se.substr(1, se.length())); //转化se的我也是... 
    
    string t = "";
    for (int i = 1; i < sc.length(); i++) {
        if (sc[i] != '.') {
            t += sc[i];
        }
    }//去掉'.' 
    if (fc == '-') {
        cout << fc;
    } //先输出符号如果是-就输出 不然就不用了 
	
	//自己忽略了一点就是第一个数一个不是 0蠢 
    if (fe == '+') //如果后面是正的话要 
	{
        if (n < t.length() - 1) 
		{
            for (int i = 0; i < t.length(); i++) {
                cout << t[i];
                if (i == n) {
                    cout << '.';
                }
            }
            cout << endl;
        }else if(n == t.length())//比如说1.23 和 3 哎笨死了  
		{
            cout << t << endl;
        }else
		{
            cout << t;
            for (int i = 0; i < n - t.length() + 1; i++) {
                cout << 0;
            }
            cout << endl;
        }
    }else{
        if (n == 1) 
		{
            cout << "0." << t << endl;
        }else
		{
            cout << "0.";
            for (int i = 0; i < n - 1; i++) {
                cout << 0;
            }
            cout << t << endl;
        }
    }
    return 0;
}

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值