1073 Scientific Notation (20 分)

1073 Scientific Notation (20 分)

Scientific notation is the way that scientists easily handle very large numbers or very small numbers. The notation matches the regular expression [±][1-9].[0-9]+E[±][0-9]+ which means that the integer portion has exactly one digit, there is at least one digit in the fractional portion, and the number and its exponent’s signs are always provided even when they are positive.

Now given a real number A in scientific notation, you are supposed to print A in the conventional notation while keeping all the significant figures.

Input Specification:
Each input contains one test case. For each case, there is one line containing the real number A in scientific notation. The number is no more than 9999 bytes in length and the exponent’s absolute value is no more than 9999.

Output Specification:
For each test case, print in one line the input number A in the conventional notation, with all the significant figures kept, including trailing zeros.

Sample Input 1:
+1.23400E-03
Sample Output 1:
0.00123400
Sample Input 2:
-1.2E+10
Sample Output 2:
-12000000000

AC代码

#include <iostream>
#include <string>
using namespace std;
int main() {
	string Sc;
	cin >> Sc;	//得到科学记数法表示
	int Mark = 0;	//初始默认为正数
	if (Sc[0] == '-') Mark = 1;	//判断为负数
	char Num[10005];
	Num[2] = Sc[1];
	int pos = 3, cnt = 0, ret = 0;
	while (Sc[pos] != 'E') { Num[pos] = Sc[pos]; cnt++; pos++; }	//得到小数点后的数字存储并计数
	int npos = pos;
	if (Sc[++pos] == '-') ret = 1;
	while (Sc[++pos] == '0');	//跳过前导零
	int index = 0;
	while (pos < Sc.size()) index = index * 10 + (Sc[pos++] - '0');	//得到指数
	if (ret) {	//指数为负
		if (Mark) cout << "-0.";
		else cout << "0.";	//判断数字正负
		for (int i = 0; i < index - 1; i++) cout << "0";	//输出小数点后的零
		for (int i = 2; i < npos; i++) cout << Num[i];
	}
	else {	//指数为正
		if (Mark) cout << "-";	//数字为负
		if ((npos - 3) <= index) {	//当正指数大于等于当前数
			for (int i = 2; i < npos; i++) cout << Num[i];
			for (int i = 0; i < index + 3 - npos; i++) cout << "0";		//输出后面的零
		}
		else {	//当正指数小于当前数
			for (int i = 2; i < index + 3; i++) cout << Num[i];	//输出小数点前的部分
			cout << ".";
			for (int i = index + 3; i < npos; i++) cout << Num[i];	//输出小数点后的部分
		}
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值