1117 Eddington Number(25 分)

1117 Eddington Number(25 分)

British astronomer Eddington liked to ride a bike. It is said that in order to show off his skill, he has even defined an "Eddington number", E -- that is, the maximum integer E such that it is for E days that one rides more than E miles. Eddington's own E was 87.

Now given everyday's distances that one rides for N days, you are supposed to find the corresponding E (≤N).

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10​5​​), the days of continuous riding. Then N non-negative integers are given in the next line, being the riding distances of everyday.

Output Specification:

For each case, print in a line the Eddington number for these N days.

Sample Input:

10
6 7 6 9 3 10 8 2 7 8

Sample Output:

6

嗯。。。就是要求最大的E 在N天中骑车连续超过E天 记得是严格超过....

我就是整体wa在这里 刚开始没有注意到 除了第一个测试点其他都是错的  后来改过来之后还是wa了一发

主要的原因是万一连最小的都没有呢 初始E的时候忘记-1了嘿嘿嘿

代码:

#include<bits/stdc++.h>
using namespace std;
const int N = 1e5+5; 
int a[N];
int main()
{
	int n;
	scanf("%d",&n);
	for(int i = 1; i <= n; i++)
		scanf("%d",&a[i]);	
	sort(a+1,a+1+n);
	int now = 1;
	int E = a[1]-1;
	for(int i = a[1];i <= a[n]; i++)
	{
		if(n - now + 1 < i )break;
		while(a[now] <= i && now <=n) now++;	
		if(n - now + 1 >= i)
			E = i; 
	} 
	printf("%d\n",E);
	return 0;
}

 

哪个时候的注释:

2----10
    2 <= 2 ? 没有 now = 1
        10 > 2 E = 2
    2 <= 3 ? 是 now = 2
    3 <= 3 ? 没有now=2
        10-2+1>=3 E=3;
    3 <= 4 ? 是 now=3
    6 <= 4 ? 没有 now = 3
        10-3+1>=4  E=4
    6 <= 5 ? 没有 now = 3
         10-3+1>=5  E=5
    6 <= 6 ? 没有 now = 3
         10-3+1>=6  E=6
    7 <= 6 ?没有 now++= 4 now++=5
    7 <= 7 ?没有 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值