1125 Chain the Ropes(25 分)

1125 Chain the Ropes(25 分)

Given some segments of rope, you are supposed to chain them into one rope. Each time you may only fold two segments into loops and chain them into one piece, as shown by the figure. The resulting chain will be treated as another segment of rope and can be folded again. After each chaining, the lengths of the original two segments will be halved.

rope.jpg

Your job is to make the longest possible rope out of N given segments.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (2≤N≤10​4​​). Then N positive integer lengths of the segments are given in the next line, separated by spaces. All the integers are no more than 10​4​​.

Output Specification:

For each case, print in a line the length of the longest possible rope that can be made by the given segments. The result must be rounded to the nearest integer that is no greater than the maximum length.

Sample Input:

8
10 15 12 3 4 13 1 15

Sample Output:

14

 

我看不懂题目意思  其中最关键的一个词是 halved

就是优先队列重载 小在前

代码

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#include<queue>
using namespace std;
priority_queue<int,vector<int>,greater<int> >qu;
int main()
{
	int n,x;
	scanf("%d",&n);
	for(int i = 1; i <= n; i++)
	{
		scanf("%d",&x);
		qu.push(x);
	}
	while(!qu.empty())
	{
		int tmp = qu.top();
		qu.pop();
		if(qu.empty()){
			printf("%d\n",tmp);
			return 0;
		}
		int now = qu.top();
		qu.pop(); 
		double gg = (now + tmp)*1.0 / 2;
	//	if(gg-int(gg) >= 0.5)
	//		gg += 1;
		qu.push(int(gg));
	//	printf("%d--\n",(int)gg);
	}
	return 0;
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值