1126 Eulerian Path(25 分)

1126 Eulerian Path(25 分)

In graph theory, an Eulerian path is a path in a graph which visits every edge exactly once. Similarly, an Eulerian circuit is an Eulerian path which starts and ends on the same vertex. They were first discussed by Leonhard Euler while solving the famous Seven Bridges of Konigsberg problem in 1736. It has been proven that connected graphs with all vertices of even degree have an Eulerian circuit, and such graphs are called Eulerian. If there are exactly two vertices of odd degree, all Eulerian paths start at one of them and end at the other. A graph that has an Eulerian path but not an Eulerian circuit is called semi-Eulerian. (Cited from https://en.wikipedia.org/wiki/Eulerian_path)

Given an undirected graph, you are supposed to tell if it is Eulerian, semi-Eulerian, or non-Eulerian.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 2 numbers N (≤ 500), and M, which are the total number of vertices, and the number of edges, respectively. Then M lines follow, each describes an edge by giving the two ends of the edge (the vertices are numbered from 1 to N).

Output Specification:

For each test case, first print in a line the degrees of the vertices in ascending order of their indices. Then in the next line print your conclusion about the graph -- either Eulerian, Semi-Eulerian, or Non-Eulerian. Note that all the numbers in the first line must be separated by exactly 1 space, and there must be no extra space at the beginning or the end of the line.

Sample Input 1:

7 12
5 7
1 2
1 3
2 3
2 4
3 4
5 2
7 6
6 3
4 5
6 4
5 6

Sample Output 1:

2 4 4 4 4 4 2
Eulerian

Sample Input 2:

6 10
1 2
1 3
2 3
2 4
3 4
5 2
6 3
4 5
6 4
5 6

Sample Output 2:

2 4 4 4 3 3
Semi-Eulerian

Sample Input 3:

5 8
1 2
2 5
5 4
4 1
1 3
3 2
3 4
5 3

Sample Output 3:

3 3 4 3 3
Non-Eulerian

 

欧拉 记得判断是否连通

代码

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#include<vector>
using namespace std;
vector<int>vec[505];
int pre[505];
void init(int n){
	for(int i = 1 ; i <= n ;i++)
		pre[i] = i;
}
int find(int x){
	if (x == pre[x])
		return x;
	return pre[x] = find(pre[x]);
}
void merge(int x,int y){
	int fx= find(x);
	int fy= find(y);
	if(fx!=fy)
		pre[fx] = fy;
}
int main()
{
	int n,m,a,b;
	scanf("%d%d",&n,&m);
	init(n);
	for(int i = 1; i <= m ;i++)
	{
		scanf("%d%d",&a,&b);
		vec[a].push_back(b);
		vec[b].push_back(a);
		merge(a,b);
	}
	int odd = 0;
	for(int i = 1; i <= n ;i++)
	{
		int len = vec[i].size();
		if(len % 2 ==1)
			odd++;
		printf("%d%c",len," \n"[i==n]);
	}	
	
	int cnt = 0;
	for(int i = 1; i <= n; i++)
	{
		if(find(i) == i)
			cnt++;
	}
	if(cnt == 1 && odd == 0)
		printf("Eulerian\n");
	else if(cnt == 1 && odd ==2 )
		printf("Semi-Eulerian\n");
	else 
		printf("Non-Eulerian\n");
	return 0;
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
很抱歉,作为一个文本AI助手,我无法提供视频资源。但是我可以为您提供欧拉回路算法的编程示例。以下是一个使用Python实现的欧拉回路算法的示例代码: ```python from collections import defaultdict class Graph: def __init__(self): self.graph = defaultdict(list) def add_edge(self, u, v): self.graph[u].append(v) self.graph[v].append(u) def dfs(self, v, visited): visited[v] = True for i in self.graph[v]: if visited[i] == False: self.dfs(i, visited) def is_connected(self): visited = [False] * (max(self.graph) + 1) for i in self.graph: if len(self.graph[i]) > 0: self.dfs(i, visited) break for i in self.graph: if visited[i] == False and len(self.graph[i]) > 0: return False return True def is_eulerian(self): if self.is_connected() == False: return False odd_degree_count = 0 for i in self.graph: if len(self.graph[i]) % 2 != 0: odd_degree_count += 1 if odd_degree_count == 0: return True elif odd_degree_count == 2: return True else: return False def eulerian_path(self): if self.is_eulerian() == False: return "No Eulerian path exists." else: return "Eulerian path exists." # 创建一个图对象 g = Graph() # 添加边 g.add_edge(1, 2) g.add_edge(1, 3) g.add_edge(2, 3) g.add_edge(2, 4) g.add_edge(3, 4) # 判断是否存在欧拉回路 print(g.eulerian_path()) ``` 这段代码使用了邻接表来表示图的存储结构,并使用深度优先搜索算法来判断图是否连通。然后,根据图的度数来判断是否存在欧拉回路。最后,根据判断结果输出相应的信息。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值