1057 Stack (30)(30 分)

1057 Stack (30)(30 分)

Stack is one of the most fundamental data structures, which is based on the principle of Last In First Out (LIFO). The basic operations include Push (inserting an element onto the top position) and Pop (deleting the top element). Now you are supposed to implement a stack with an extra operation: PeekMedian -- return the median value of all the elements in the stack. With N elements, the median value is defined to be the (N/2)-th smallest element if N is even, or ((N+1)/2)-th if N is odd.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<= 10^5^). Then N lines follow, each contains a command in one of the following 3 formats:

Push key\ Pop\ PeekMedian

where key is a positive integer no more than 10^5^.

Output Specification:

For each Push command, insert key into the stack and output nothing. For each Pop or PeekMedian command, print in a line the corresponding returned value. If the command is invalid, print "Invalid" instead.

Sample Input:

17
Pop
PeekMedian
Push 3
PeekMedian
Push 2
PeekMedian
Push 1
PeekMedian
Pop
Pop
Push 5
Push 4
PeekMedian
Pop
Pop
Pop
Pop

Sample Output:

Invalid
Invalid
3
2
2
1
2
4
4
5
3
Invalid

 

滴越来越差劲..........

转载来的....树状数组求中位数

peekmedian操作,找到第(n+1)/2[题目是说偶数n/2,奇数(n+1)/2但是其实取整一下都是(n+1)/2]

怎么求能就是树状数组 然后二分查找

转载来自:https://blog.csdn.net/waterboy_cj/article/details/81320311

代码;

#include <bits/stdc++.h>
using namespace std;
const int maxn = 100010;
using namespace std;
stack<int> s;//栈只用来操作pop和push
int c[maxn];//c才是用来peekmedian的
int lowbit(int x)
{
	return x & (-x);
}
void update(int x, int v)
{
	for (int i = x; i < maxn; i += lowbit(i))
		c[i] += v;
}
int getsum(int x) 
{
	int sum = 0;
	for (int i = x; i >= 1; i -= lowbit(i))
		sum += c[i];
	return sum;
}
void PeekMedian() 
{
	int left = 1 ,right = maxn, mid , k = (s.size() + 1) / 2 ;
	while(left < right)
	{
		mid = (left + right) / 2;
		if(getsum(mid) >= k)
			right = mid;
		else 
			left = mid + 1;
	}
	printf("%d\n", left);
}
int main() 
{
	int n, temp;
	scanf("%d", &n);
	char str[20];
	while(n--)
	{
		scanf("%s", str);
		if (str[1] == 'u') 
		{
			scanf("%d", &temp);
			s.push(temp);
			update(temp, 1);//push就是+1
		}
		else if (str[1] == 'o')
		{
			if (!s.empty()) 
			{
				update(s.top(), -1);//删除就是-1
				printf("%d\n", s.top());
				s.pop();
			}
			else 
				printf("Invalid\n");
		}
		else 
		{
			if (!s.empty())
				PeekMedian();
			else
				printf("Invalid\n");
		}
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值