PAT甲级 1057 Stack(30) (树状数组+二分+栈)

题目

Stack is one of the most fundamental data structures, which is based on the principle of Last In First Out (LIFO). The basic operations include Push (inserting an element onto the top position) and Pop (deleting the top element). Now you are supposed to implement a stack with an extra operation: PeekMedian -- return the median value of all the elements in the stack. With N elements, the median value is defined to be the (N/2)-th smallest element if N is even, or ((N+1)/2)-th if N is odd.

输入

Each input file contains one test case. For each case, the first line contains a positive integer N (≤10^{5}). Then N lines follow, each contains a command in one of the following 3 formats:

Push key
Pop
PeekMedian

where key is a positive integer no more than 10^{5}.

输出

For each Push command, insert key into the stack and output nothing. For each Pop or PeekMedian command, print in a line the corresponding returned value. If the command is invalid, print Invalid instead.

样例输入 

17
Pop
PeekMedian
Push 3
PeekMedian
Push 2
PeekMedian
Push 1
PeekMedian
Pop
Pop
Push 5
Push 4
PeekMedian
Pop
Pop
Pop
Pop

样例输出 

Invalid
Invalid
3
2
2
1
2
4
4
5
3
Invalid

题意理解

让你维护一个栈 入栈和出栈没啥好说的 还有一个新的操作

就是让你找到栈的里面所有元素的个数的中位数元素是什么

元素个数为奇数就是找到(N+1)/2 个元素是什么

偶数就是 N/2

其实由于C++的特性 小技巧就是 无论奇数偶数(N+1)/2 是一样的因为是向下取整的

所有直接用 (N+1)/2 代表中位数即可

那么我们怎么维护中位数呢

我们用一个树状数组 来记录个数 树状数组本来是维护前缀和 此时我们维护这个数的出现个数

那么我们怎么找中位数呢 我们用二分 找到出现前面出现数的次数是 (N+1)/2 

那么那个数就是中位数

check条件就是如果出现次数大于等于k那么右区间缩过来 

代码 

#include<bits/stdc++.h>
using namespace std;
const int N=2e5+10;
const int INF=0x3f3f3f3f;
stack<int>st;
int n,m;
int tr[N];
int lowbit(int x){
    return x&-x;
}
int sum(int x){
    int res=0;
    for(int i=x;i;i-=lowbit(i))res+=tr[i];
    return res;
}
void add(int x,int c){
    for(int i=x;i<N;i+=lowbit(i))tr[i]+=c;
}
int find(){
    int l=1,r=N,k=(st.size()+1)/2;
    while(l<r){
        int mid=l+r>>1;
        if(sum(mid)>=k)r=mid;
        else l=mid+1;
    }
    return l;
}
           
int main(){
    scanf("%d",&m);
    char op[25];
    while(m--){
        scanf("%s",op);
        if(op[1]=='o'){
            //pop
            if(!st.size()){
                puts("Invalid");
                continue;
            }
            else {
                int x=st.top();
                st.pop();
                add(x,-1);
                printf("%d\n",x);
            }
        }
        else if(op[1]=='u'){
            //push
            int x;
            scanf("%d",&x);
            st.push(x);
            add(x,1);
        }
        else if(op[1]=='e'){
            //peekmedian
            if(!st.size()){
                puts("Invalid");
                continue;
            }
            else {
                int t=find();
                printf("%d\n",t);
            }
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
树状数组、并查集和单调是常用的数据结构,它们在算法和数据处理中有着广泛的应用。 1. 树状数组(Binary Indexed Tree)是一种用于高效处理区间和的数据结构。它可以在O(logN)的时间内完成单点更新和区间查询操作。树状数组主要用于解决一些前缀和相关的问题,例如计算数组的前缀和、区间和等。树状数组的基本原理是利用二进制表示的索引来维护和查询区间和。具体操作包括更新操作和查询操作。 2. 并查集(Union-Find Set)是一种用于处理不相交集合的数据结构。它支持合并集合和查询元素所在集合的操作。并查集的基本原理是使用树形结构来表示集合,每个节点储存其父节点的信息。通过路径压缩和按秩合并的优化策略,可以实现较快的合并和查询操作。并查集常用于解决一些连通性问题,例如判断图中的连通分量、判断两个元素是否在同一个集合中等。 3. 单调(Monotonic Stack)是一种特殊的数据结构,它可以在O(N)的时间内解决一些与单调性相关的问题。单调的基本原理是维护一个单调递增或单调递减的,通过比较顶元素和当前元素的大小关系来确定中元素的位置。单调常用于解决一些与最大值、最小值、下一个更大元素、下一个更小元素等相关的问题。 以下是对树状数组、并查集和单调的简单介绍。如果你对其中某个数据结构感兴趣,我可以为你提供更详细的解释和示例代码。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值