1076 Forwards on Weibo(30 分)

1076 Forwards on Weibo(30 分)

Weibo is known as the Chinese version of Twitter. One user on Weibo may have many followers, and may follow many other users as well. Hence a social network is formed with followers relations. When a user makes a post on Weibo, all his/her followers can view and forward his/her post, which can then be forwarded again by their followers. Now given a social network, you are supposed to calculate the maximum potential amount of forwards for any specific user, assuming that only L levels of indirect followers are counted.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤1000), the number of users; and L (≤6), the number of levels of indirect followers that are counted. Hence it is assumed that all the users are numbered from 1 to N. Then N lines follow, each in the format:

M[i] user_list[i]

where M[i] (≤100) is the total number of people that user[i] follows; and user_list[i] is a list of the M[i] users that followed by user[i]. It is guaranteed that no one can follow oneself. All the numbers are separated by a space.

Then finally a positive K is given, followed by K UserID's for query.

Output Specification:

For each UserID, you are supposed to print in one line the maximum potential amount of forwards this user can triger, assuming that everyone who can view the initial post will forward it once, and that only L levels of indirect followers are counted.

Sample Input:

7 3
3 2 3 4
0
2 5 6
2 3 1
2 3 4
1 4
1 5
2 2 6

Sample Output:

4
5

好吧 题目意思我也没有明白依旧是看博客的  就是最大层数下,假设他的每个粉丝都会转发 求最大转发数

输入的是 谁是i的追随者

深搜写超时了,我尽力优化了,优化不出来最后一个测试点实在不知道怎么搞

深搜代码27分:

#include<bits/stdc++.h>
#define INF 0x3f3f3f3f 
using namespace std;
struct node
{
	int id;
	vector<int>vec;
	int num;
}s[1005];
int n,k,cnt;
set<int>st;
void DFS(int x, int num,bool flag[],int level[])
{
	if(num == k){
		st.insert(x);
		flag[x] = true;
		return;
	}
	for(int i = 0 ; i < s[x].num; i++)
	{
		if(flag[s[x].vec[i]] == false || flag[s[x].vec[i]] == true && num < level[s[x].vec[i]])
		{
			num ++;
			st.insert(s[x].vec[i]);
			level[s[x].vec[i]] = num;
			DFS(s[x].vec[i], num,flag,level);
			num--;
		}	
	}
	return;
}
int main() 
{
	int num , x;
	scanf("%d %d",&n,&k);
	for(int p = 1; p <= n; p ++)
	{
		scanf("%d",&num);
		while(num--)
		{
			scanf("%d" ,&x);
			s[x].vec.push_back(p);
		}
	} 
	for(int i = 1; i <= n; i++)
		s[i].num = s[i].vec.size(); 
	scanf("%d",&num);
	while(num--)
	{
		int level[1005];
		for(int i = 1 ; i <= n; i++)
			level[i] = INF;
		bool flag[1005]={false};
		st.clear();
		scanf("%d",&x);
		st.insert(x);
		flag[x] = true;
		DFS(x,0,flag,level);
		int cnt = st.count(x)==1 ? st.size()-1:st.size(); 
		printf("%d\n",cnt);
	} 
	return 0;
}

 

广搜代码是AC的 我转载的.........好久没写了不知道怎么写 https://blog.csdn.net/xianyun2009/article/details/50490310

代码:

#include <cstdio>
#include <vector>
#include <queue>
using namespace std;
int n, level, tn, t, m;
vector<int> node[1005];

int find(int root){
    int s = 0;
    vector<bool> vis(n+1, false);  
    queue<pair<int, int> > que;
    que.push(make_pair(root, 0)); //把根扔进去 并且说他是0层 
    vis[root] = true; //这个东西是已经存在的 
    while (!que.empty()){
        int id = que.front().first;
        int lv = que.front().second;
        que.pop();
        if (lv >= level) continue; //如果说比那个还要大的话,那么就直接跳过好了 
        for (int i = 0; i < node[id].size(); ++i){
            if (!vis[ node[id][i] ]){
                vis[node[id][i]] = true;
                que.push(make_pair(node[id][i], lv + 1));
                ++s;
            }
        }
    }
    return s;
}
int main()
{
    scanf("%d%d", &n, &level);
    for (int i = 1; i <= n; ++i){
        scanf("%d", &tn);
        while (tn--) {
            scanf("%d", &t);
            if (t != i) node[t].push_back(i);
        }
    }
    scanf("%d", &m);
    while (m--){
        scanf("%d", &t);
        printf("%d\n",find(t)); 
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值