PAT-A1076 Forwards on Weibo 题目内容及题解

Weibo is known as the Chinese version of Twitter. One user on Weibo may have many followers, and may follow many other users as well. Hence a social network is formed with followers relations. When a user makes a post on Weibo, all his/her followers can view and forward his/her post, which can then be forwarded again by their followers. Now given a social network, you are supposed to calculate the maximum potential amount of forwards for any specific user, assuming that only L levels of indirect followers are counted.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤1000), the number of users; and L (≤6), the number of levels of indirect followers that are counted. Hence it is assumed that all the users are numbered from 1 to N. Then N lines follow, each in the format:

M[i] user_list[i]

where M[i] (≤100) is the total number of people that user[i] follows; and user_list[i] is a list of the M[i] users that followed by user[i]. It is guaranteed that no one can follow oneself. All the numbers are separated by a space.

Then finally a positive K is given, followed by K UserID's for query.

Output Specification:

For each UserID, you are supposed to print in one line the maximum potential amount of forwards this user can triger, assuming that everyone who can view the initial post will forward it once, and that only L levels of indirect followers are counted.

Sample Input:

7 3
3 2 3 4
0
2 5 6
2 3 1
2 3 4
1 4
1 5
2 2 6

Sample Output:

4
5

题目大意

题目通过输入每个用户的关注者的信息给定一个社交网络,假设只计算到某一层间接关注者,题目要求计算任何特定用户的最大转发潜在数量。

解题思路

  1. 题目给定数据为用户关注者信息,先由此信息初始化并生成一个从被关注者到关注者的有向图;
  2. 对请求序列中的每个请求使用BFS进行遍历、计数并输出;
  3. 返回零值。

代码

#include<cstdio>
#include<vector>
using namespace std;

#define maxn 1010

vector<int> Adj[maxn]; 
int inq[maxn];
int N,L;

void Init(){
    int num,a,i;
    scanf("%d%d",&N,&L);
    for(i=1;i<=N;i++){
        scanf("%d",&num);
        while(num--){
            scanf("%d",&a);
            Adj[a].push_back(i);
        }
    }
}

int BFS(int s){
    int Queue[maxn*6];
    int front=0,rear=0;
    int now,level=0,cnt=-1,i;
    for(i=1;i<=N;i++){
        inq[i]=0;
    }
    Queue[rear++]=s;
    inq[s]=1;
    Queue[rear++]=-1;
    while(rear>front){
        now=Queue[front++];
        if(now==-1){
            Queue[rear++]=-1;
            level++;
            if(level<=L){
                continue;
            }else{
                break;
            }
        }
        cnt++;
        for(i=0;i<Adj[now].size();i++){
            if(inq[Adj[now][i]]==0){
                Queue[rear++]=Adj[now][i];
                inq[Adj[now][i]]=1;
            }
        }
    }
    return cnt;
}

int main(){
    int K,Query;
    Init();
    scanf("%d",&K);
    while(K--){
        scanf("%d",&Query);
        printf("%d\n",BFS(Query));
    }
    return 0;
}

运行结果

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
See the 'Note about fast-forwards' in 'git push --help' for details是在git push命令的帮助文档中提到的一条注意事项。[1] 这个提示是关于在使用git push命令时可能出现的一种错误情况,即推送失败,提示"non-fast-forward"。 这种情况通常是因为你当前分支的最新提交落后于远程分支的提交,需要先合并远程分支的更改(例如使用git pull命令),然后再次尝试推送。如果想要了解更多关于fast-forward的详细信息,可以参考git push的帮助文档中的相关说明。<span class="em">1</span><span class="em">2</span><span class="em">3</span> #### 引用[.reference_title] - *1* [【git push报错】:See the ‘Note about fast-forwards‘ in ‘git push --help‘ for details](https://blog.csdn.net/scorpio_j/article/details/114756383)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_1"}}] [.reference_item style="max-width: 50%"] - *2* *3* [git 无法push远程仓库 Note about fast-forwards 问题解决](https://blog.csdn.net/weixin_42596434/article/details/88759295)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_1"}}] [.reference_item style="max-width: 50%"] [ .reference_list ]

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值