1021 Deepest Root(25 分)

1021 Deepest Root(25 分)

A graph which is connected and acyclic can be considered a tree. The hight of the tree depends on the selected root. Now you are supposed to find the root that results in a highest tree. Such a root is called the deepest root.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤10​4​​) which is the number of nodes, and hence the nodes are numbered from 1 to N. Then N−1 lines follow, each describes an edge by given the two adjacent nodes' numbers.

Output Specification:

For each test case, print each of the deepest roots in a line. If such a root is not unique, print them in increasing order of their numbers. In case that the given graph is not a tree, print Error: K components where K is the number of connected components in the graph.

Sample Input 1:

5
1 2
1 3
1 4
2 5

Sample Output 1:

3
4
5

Sample Input 2:

5
1 3
1 4
2 5
3 4

Sample Output 2:

Error: 2 components

 

并查集和DFS

#include<bits/stdc++.h>
using namespace std;
const int maxn = 1e4+10;
int pre[maxn];
vector<int>s[maxn];
int step[maxn];
bool flag[maxn];
void init(int n)
{
	for(int i =1 ; i <= n ;i++)
		pre[i] = i;
}
int find(int x)
{
	if (pre[x] == x)
		return x;
	else 
		return pre[x] = find(pre[x]);
}
void merge(int x,int y)
{
	int fx = find(x);
	int fy = find(y);
	if(fx != fy)
		pre[fx] = fy;
	return;
}
int DFS(int x)
{
	int ans = 0;
	if(flag[x])
		return 0;
	flag[x] = true;
	int m = s[x].size();
	for(int i = 0 ; i < m; i++)
	{
		if(! flag[s[x][i]])
		{
			int tmp = DFS(s[x][i]);
			ans = max(ans,tmp);
		}	
	}	
	return ans + 1;
}
int main()
{
	int n,x,y;
	scanf("%d",&n);
	init(n);
	for(int i = 1 ; i < n; i++ )
	{
		scanf("%d %d",&x,&y);
		s[x].push_back(y);
		s[y].push_back(x);
		merge(x,y);
	}
	int cnt = 0;
	for(int i = 1; i <= n ; i++)
	{
		if(pre[i] == i)
			cnt++;
	}
	if(cnt != 1)
	{
		printf("Error: %d components\n",cnt);
		return 0;
	}
	for(int i = 1; i <= n; i++)
	{
		for(int j = 1; j <= n; j++)
			flag[j] = false;
		
		step[i] = DFS(i);
	}	
	int num = 0 ;
	for(int i = 1; i <= n ; i ++ )
		num = max(num,step[i]);
	for(int i = 1; i <= n; i++)
	{
		if(step[i] == num)
			printf("%d\n",i);
	}
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值