1021 Deepest Root(25 分)
A graph which is connected and acyclic can be considered a tree. The hight of the tree depends on the selected root. Now you are supposed to find the root that results in a highest tree. Such a root is called the deepest root.
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤104) which is the number of nodes, and hence the nodes are numbered from 1 to N. Then N−1 lines follow, each describes an edge by given the two adjacent nodes' numbers.
Output Specification:
For each test case, print each of the deepest roots in a line. If such a root is not unique, print them in increasing order of their numbers. In case that the given graph is not a tree, print Error: K components
where K
is the number of connected components in the graph.
Sample Input 1:
5
1 2
1 3
1 4
2 5
Sample Output 1:
3
4
5
Sample Input 2:
5
1 3
1 4
2 5
3 4
Sample Output 2:
Error: 2 components
并查集和DFS
#include<bits/stdc++.h>
using namespace std;
const int maxn = 1e4+10;
int pre[maxn];
vector<int>s[maxn];
int step[maxn];
bool flag[maxn];
void init(int n)
{
for(int i =1 ; i <= n ;i++)
pre[i] = i;
}
int find(int x)
{
if (pre[x] == x)
return x;
else
return pre[x] = find(pre[x]);
}
void merge(int x,int y)
{
int fx = find(x);
int fy = find(y);
if(fx != fy)
pre[fx] = fy;
return;
}
int DFS(int x)
{
int ans = 0;
if(flag[x])
return 0;
flag[x] = true;
int m = s[x].size();
for(int i = 0 ; i < m; i++)
{
if(! flag[s[x][i]])
{
int tmp = DFS(s[x][i]);
ans = max(ans,tmp);
}
}
return ans + 1;
}
int main()
{
int n,x,y;
scanf("%d",&n);
init(n);
for(int i = 1 ; i < n; i++ )
{
scanf("%d %d",&x,&y);
s[x].push_back(y);
s[y].push_back(x);
merge(x,y);
}
int cnt = 0;
for(int i = 1; i <= n ; i++)
{
if(pre[i] == i)
cnt++;
}
if(cnt != 1)
{
printf("Error: %d components\n",cnt);
return 0;
}
for(int i = 1; i <= n; i++)
{
for(int j = 1; j <= n; j++)
flag[j] = false;
step[i] = DFS(i);
}
int num = 0 ;
for(int i = 1; i <= n ; i ++ )
num = max(num,step[i]);
for(int i = 1; i <= n; i++)
{
if(step[i] == num)
printf("%d\n",i);
}
return 0;
}