1130 Infix Expression(25 分)
Given a syntax tree (binary), you are supposed to output the corresponding infix expression, with parentheses reflecting the precedences of the operators.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 20) which is the total number of nodes in the syntax tree. Then N lines follow, each gives the information of a node (the i-th line corresponds to the i-th node) in the format:
data left_child right_child
where data
is a string of no more than 10 characters, left_child
and right_child
are the indices of this node's left and right children, respectively. The nodes are indexed from 1 to N. The NULL link is represented by −1. The figures 1 and 2 correspond to the samples 1 and 2, respectively.
Figure 1 | Figure 2 |
Output Specification:
For each case, print in a line the infix expression, with parentheses reflecting the precedences of the operators. Note that there must be no extra parentheses for the final expression, as is shown by the samples. There must be no space between any symbols.
Sample Input 1:
8
* 8 7
a -1 -1
* 4 1
+ 2 5
b -1 -1
d -1 -1
- -1 6
c -1 -1
Sample Output 1:
(a+b)*(c*(-d))
Sample Input 2:
8
2.35 -1 -1
* 6 1
- -1 4
% 7 8
+ 2 3
a -1 -1
str -1 -1
871 -1 -1
Sample Output 2:
(a*2.35)+(-(str%871))
脑子疼,这题其实一开始我并没有抓住重点。。。。。怎么说?
先找到根节点之后之后发现除了根节点和叶子节点外都要加括号~~~
代码:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<vector>
#include<map>
#include<queue>
using namespace std;
struct node
{
char data[15];
int left,right;
}tree[25];
int view[25],root;
void InOrder(int v)
{
if(v != -1){
if(v != root && (tree[v].left != -1 || tree[v].right != -1))
printf("(");
InOrder(tree[v].left);
printf("%s",tree[v].data);
InOrder(tree[v].right);
if(v != root && (tree[v].left != -1 || tree[v].right != -1))
printf(")");
}
}
int main()
{
int n ;
scanf("%d",&n);
for(int i = 1; i <= n; i++)
{
scanf("%s %d %d",tree[i].data,&tree[i].left, &tree[i].right);
view[tree[i].left] = 1;
view[tree[i].right] = 1;
}
for(int i = 1; i <= n; i++)
{
if(view[i] == 0)
{
root = i ;
break;
}
}
InOrder(root);
return 0;
}