1068 Find More Coins(30 分)
Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she must pay the exact amount. Since she has as many as 104 coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find some coins to pay for it.
Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive numbers: N
(≤104, the total number of coins) and M
(≤102, the amount of money Eva has to pay). The second line contains N
face values of the coins, which are all positive numbers. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print in one line the face values V1≤V2≤⋯≤Vk such that V1+V2+⋯+Vk=M
. All the numbers must be separated by a space, and there must be no extra space at the end of the line. If such a solution is not unique, output the smallest sequence. If there is no solution, output "No Solution" instead.
Note: sequence {A[1], A[2], ...} is said to be "smaller" than sequence {B[1], B[2], ...} if there exists k≥1 such that A[i]=B[i] for all i<k, and A[k] < B[k].
Sample Input 1:
8 9
5 9 8 7 2 3 4 1
Sample Output 1:
1 3 5
Sample Input 2:
4 8
7 2 4 3
Sample Output 2:
No Solution
这题有点懵逼.....emmm是01背包.....求出来之后的话回溯下 代码里面详解
具体代码我是转载的:https://www.jianshu.com/p/20dac38241a5
code
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<vector>
using namespace std;
const int maxn = 1e4+10;
int digit[maxn];
int dp[maxn];
bool flag[maxn][110];
bool cmp(int a, int b)
{
return a > b;
}
int main()
{
int n,m;
scanf("%d%d",&n,&m);
for(int i = 1; i <= n; i++)
scanf("%d",&digit[i]);
sort(digit+1,digit+1+n,cmp);
/*
为什么要排序? 和下面的<=挂钩
排序之后是从大到小,针对每一个大的能到达条件的都选择了
<= 如果没有等于号的话,输出的其实是前面大的那些
有了=== 因为从大到小,后面小的也是有机会的
*/
for(int i = 1; i <= n; i++)
{
for(int j = m; j >= digit[i]; j--)
{
if(dp[j] <= dp[j - digit[i]] + digit[i]) //必须取等号否则就是最大的来了
{
dp[j] = dp[j - digit[i]] + digit[i]; //跟踪哪个物品被选择
flag[i][j] = true;
}
}
}
if(dp[m] != m)
{
printf("No Solution\n");
return 0;
}
int j = m, i = n;
while(1)
{
if(flag[i][j] == true){
printf("%d",digit[i]);
j = j - digit[i];
if(j != 0)
printf(" ");
}
i--;
if(j == 0 || i == 0)
break;
}
printf("\n");
/*
这边是回溯因为dp[m] = m所以说....从后面i找起...........
判断对应的flag[i][j]是否为真 如果为真那么 减掉对应的digit[i]
*/
return 0;
}