1068 Find More Coins (30 分)

Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she must pay the exact amount. Since she has as many as 10
​4
​​ coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find some coins to pay for it.

Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (≤10
​4
​​ , the total number of coins) and M (≤10
​2
​​ , the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print in one line the face values V
​1
​​ ≤V
​2
​​ ≤⋯≤V
​k
​​ such that V
​1
​​ +V
​2
​​ +⋯+V
​k
​​ =M. All the numbers must be separated by a space, and there must be no extra space at the end of the line. If such a solution is not unique, output the smallest sequence. If there is no solution, output “No Solution” instead.

Note: sequence {A[1], A[2], …} is said to be “smaller” than sequence {B[1], B[2], …} if there exists k≥1 such that A[i]=B[i] for all i<k, and A[k] < B[k].

Sample Input 1:
8 9
5 9 8 7 2 3 4 1
Sample Output 1:
1 3 5
Sample Input 2:
4 8
7 2 4 3
Sample Output 2:
No Solution

题意是01背包问题,给定一堆硬币,和一个目标值,选出和为目标值的最小序列。
数据量还是比较小的,直接暴力深搜了,最后一个点的情况是所有的硬币加起来都没有给定的目标值大,所以特判一下就能过了。
主要是目标值给的太小了,如果稍微大一点深搜就很吃力了。

#include<bits/stdc++.h>
using namespace std;
void dfs(vector<int>& coins, int m, int cur, vector<int>& path, vector<int>& ret){
	if (m < 0||ret.size()) return;
	if (m == 0){
		ret = path;
		return;
	}
	for (int i = cur + 1; i < coins.size(); i++){
        path.push_back(coins[i]);
		dfs(coins, m - coins[i], i, path, ret);
		path.pop_back();
    }
}
int main()
{
	int n, m;
	cin >> n >> m;
	vector<int>coins(n);
	for (int i = 0; i < n; i++)
		cin >> coins[i];
    if(accumulate(coins.begin(),coins.end(),0)<m){
        cout << "No Solution";
        return 0;
    }
	sort(coins.begin(), coins.end());
	vector<int>path, ret;
	dfs(coins, m, -1, path, ret);
	if (ret.size() == 0)
		cout << "No Solution";
	else
		for (int i = 0; i <ret.size(); i++)
			cout <<( i==0 ? "" : " ") << ret[i];
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值