1151 LCA in a Binary Tree(30 分)

1151 LCA in a Binary Tree(30 分)

The lowest common ancestor (LCA) of two nodes U and V in a tree is the deepest node that has both U and V as descendants.

Given any two nodes in a binary tree, you are supposed to find their LCA.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 1,000), the number of pairs of nodes to be tested; and N (≤ 10,000), the number of keys in the binary tree, respectively. In each of the following two lines, N distinct integers are given as the inorder and preorder traversal sequences of the binary tree, respectively. It is guaranteed that the binary tree can be uniquely determined by the input sequences. Then M lines follow, each contains a pair of integer keys U and V. All the keys are in the range of int.

Output Specification:

For each given pair of U and V, print in a line LCA of U and V is A. if the LCA is found and A is the key. But if A is one of U and V, print X is an ancestor of Y. where X is A and Y is the other node. If U or V is not found in the binary tree, print in a line ERROR: U is not found. or ERROR: V is not found. or ERROR: U and V are not found..

Sample Input:

6 8
7 2 3 4 6 5 1 8
5 3 7 2 6 4 8 1
2 6
8 1
7 9
12 -3
0 8
99 99

Sample Output:

LCA of 2 and 6 is 3.
8 is an ancestor of 1.
ERROR: 9 is not found.
ERROR: 12 and -3 are not found.
ERROR: 0 is not found.
ERROR: 99 and 99 are not found.

 

这题是根据中序和先序建立树然后输出LCA

我只拿了20分  自己不会做也是应该的。。。。因为自己的LCA算法不会....................

代码:

#include<bits/stdc++.h>
using namespace std;
struct node
{
	int val;
	node *left;
	node *right;
};
node* CreatTree(int pre[],int in[],int pl,int pr,int il,int ir) 
{
	if(pl > pr )return NULL;
	node *root = (node*)malloc(sizeof(node));
	root->val = pre[pl];
	root->left = NULL;
	root->right = NULL;
	int pos;
	for(int i = il; i<= ir ;i++)
	{
		if (pre[pl] == in[i])
		{
			pos = i;
			break;
		}
	}
		
	root->left = CreatTree(pre,in,pl+1,pos-il+pl,il,pos-1) ;
	root->right = CreatTree(pre,in,pos-il+pl+1,pr,pos+1,ir) ;
	return root;
} //还原树 

node *LCA(node *root, int u, int v) {  //查找两节点最近祖先 
        if (root == NULL) return NULL;
        if (root->val == u || root->val == v) return root;
        node *left =LCA(root->left,u,v);
        node *right = LCA(root->right,u,v);
        if (left && right ) return root;  //u,v分别位于左右子树的情况
        return left == NULL ? right : left;
}

int main()
{
	int n,num,m;
	scanf("%d%d",&m,&n);
	int pre[10005],in[10005];
	map<int,bool>mp;
	for(int i = 0; i < n; i++)
	{
		scanf("%d",&in[i]);
		mp[in[i]] = true;
	}
	for(int i = 0; i < n; i++)
		scanf("%d",&pre[i]);
		
	node *root = CreatTree(pre,in,0,n-1,0,n-1);
	int u, v;
	while(m--)
	{
		scanf("%d %d",&u,&v);
		if(mp[u] == false&& mp[v] == false)
		    printf("ERROR: %d and %d are not found.\n",u,v);
		else if(mp[u] == false)
		    printf("ERROR: %d is not found.\n",u);
		else if(mp[v] == false)
		    printf("ERROR: %d is not found.\n",v);
		else  //表示两者都存在的了 
		{
			node *temp=LCA(root,u,v);
                        if(temp->val == u || temp->val == v){
                            printf("%d is an ancestor of %d.\n",temp->val == u? u:v,temp->val==u? v:u);
                        }else{
                            printf("LCA of %d and %d is %d.\n",u,v,temp->val);
                        }
		}
	}
	return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值